Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin language problem


Jerah

Recommended Posts

I searched to see if someone had already experienced this, but couldn't find anything.

 

Up until today, my store and admin sections had been running fine.

 

I had recently set up the cache properly. The only real file of concern to me is the "also purchased" module, since I don't use the Categories or Manufacturers boxes in my template.

 

Anyhow, today I went to the Admin -> Cache Control and reset my cache files. Mainly to check how the function worked.

 

I reset the Also Purchased - OK. Reset the Man box - OK. Reset Categories -

 

Suddenly, I was confronted with this error

 

(Before anyone says anything, I have renamed my admin directory on my server but changed that name back to "admin" here for ease of understanding. I have also removed the path from the quote below. )

 

Warning: main(includes/languages/engli): failed to open stream: No such file or directory in admin/includes/application_top.php on line 133

 

Warning: main(includes/languages/engli): failed to open stream: No such file or directory in admin/includes/application_top.php on line 133

 

Fatal error: main(): Failed opening required 'includes/languages/engli' (include_path='./:/usr/local/lib/php') in admin/includes/application_top.php on line 133

 

And nothing I did in the Admin worked. I kept getting that error.

 

I checked the store, that was running fine. So this error effected only the admin.

 

It appears to me that "sh" was being stripped from the end of "english" in the language variable.

 

I checked the db via phpMyAdmin - all the language settings were OK.

 

It ended up I hardcoded "english" into "application_top.php" to allow me to access my admin pages again.

 

While this is fine for my store, I wonder if something to do with the cache reset somehow "corrupted" something that resulted in this error?

 

Can anyone shed some light on this, if not for me then for the rest of the community?

Link to comment
Share on other sites

I too have the same problem...

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/httpd/vhosts/sycentrum.se/httpsdocs/shop/includes/application_top.php on line 290

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/httpd/vhosts/sycentrum.se/httpsdocs/shop/includes/application_top.php on line 290

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/sycentrum.se/httpsdocs/shop/includes/application_top.php on line 290

 

But now I have it on all my pages, not just the admin part. :(

 

I can access the first page on both the catalog site and the admin site, but when I try to click on a link I get the error.

 

And as many other have said before "I didnt do anything", everything worked fine and the next day nothing works.

 

I am running osCommerce 2.2-MS2 on a FC1 Linux with Apache 2.0.50-1.0,

php 4.3.8-1.1, mysql 3.23.58-4 with a Plesk system.

Link to comment
Share on other sites

Somehow, it appeas we are losing the assignment of the $language variable.

 

Is anyone more familiar with the OSC code able to assist?

 

Is there something that maybe a change on the web provider side that would cause this? (Don't see how....)

 

Noxi, try hardcoding "english" (or the appropriate language file) into the relevant lines of application_top.php. I know this wont help for multi-lingual sites but at least it will give you access again.

Link to comment
Share on other sites

Thanks Jerah, I will try that, can you give me a hint on how to do that?

 

I tried to do a $language = 'english' but that only gave me a parse error

 

But even if we do get it to work with the hardcode language there seems to be some error that needs attention.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...