Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Add to Cart link not working


matte4@yahoo.com

Recommended Posts

Hello,

 

I just installed the 2.2 ver and some of the links do now work. When a user tries to create a new account and fills in all the information on the create_account.php page the continue button doesn't do anything. The mouse cursor chagnes as if it is a link, but no url is provided. Also, when you click on a product and click add to cart it does the same thing, nothing.

 

You can goto http://www.buybargainsnow.com and see what i mean.

 

Thanks for any help!

Link to comment
Share on other sites

You need to post your two configure.php files (leaving out the database user name and password) so that folks can take a look at them. It sounds as though they're not set up correctly.

 

Vger

Link to comment
Share on other sites

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://buybargainsnow.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'buybargainsnow.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/user/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '******');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', '******');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

//****************************************************************

// BG: BGI: 09/05/2003: Add Simple Template System Code

define('DIR_WS_TEMPLATE', DIR_WS_INCLUDES . 'template.html');

//****************************************************************

?>

 

thanks again!

Link to comment
Share on other sites

That looks okay. Must be something else. You could try adding the www. to your domain name and to the cookie domain, but otherwise it looks okay - and that shouldn't affect the 'add to cart' function.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...