Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Quirks with categories box


jamieC

Recommended Posts

I am currently experiencing weirdness with the categories box on a site I have been developing with OSCommerce. Depending on the product or page one is viewing, the box does weird things. Sometimes the border around it is thicker. Sometimes the border does not appear at all. Sometimes the header for the box is right justified. Sometimes it scrunched up against the what's new box above it (which I resolved by adding a BR tag in column_right.php). Check it out at http://www.athensantiqueprints.com/catalog. Specifically, If you go to Labels/Can Labels/any product you'll see the box disappears (my categories box is labeled "prints"). But if you visit any of the Children's Illustrations products there are no problems.

 

This is a problem. It makes the design look incredibly inconsistent.

 

The trouble seems to be in that some of the table tags are being truncated when the code is generated dynamically. Has anyone experienced a similar trouble? If so, how did you resolve this?

 

I would certainly appreciate any advice anyone could offer.

Link to comment
Share on other sites

Here's the code for the problem:

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr>
   <td height="14" class="infoBoxHeading"><img src="images/infobox/corner_left.gif" border="0" alt="" width="11" height="14"></td>
   <td width="100%" height="14" class="infoBoxHeading">Prints</td>
   <td height="14" class="infoBoxHeading" nowrap><img src="images/pixel_trans.gif" border="0" alt="" width="11" height="14"></td>
 </tr>
</<table border="0" width="100%" cellspacing="0" cellpadding="1" class="infoBox">

 

You'll notice that the closing TABLE tag for the header of the categories box is truncated. Why would it do this on some pages but not others when the same code is being used for all pages?

Link to comment
Share on other sites

Okay. Wanna talk about weird quirks!? I figured out what was triggering the problem. What the root of the problem is, I know not, but at least I have solved my problem for the moment.

 

My attribute sets contribution was adding a drop-down menu. The options were so long that they were causing the truncating of the tags. I reduced the size of my options in the menu and the problem went away.

 

Why? Who knows.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...