Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Fatal Error


kaboom

Recommended Posts

You havent installed mysql or you havent enabled the mysql extension for php.

 

create a new file called info.php and put the following code into it

 

<?php

phpinfo();

?>

 

Run that in your browser by going to http://localhost/info.php

 

and you should see a page of php configuration information. Scroll down the page and you should see a section wilth mysql details in. If that is not there you need to enable mysql for php.

 

This is likely to be done by copying the libmysql.dll to the windows\system32 directory and editing php.ini which is normally found in your windows directory.

 

Look at the extensions section which should tell you what you need to change.

 

Then restart the computer and it should work ok.

Mark Evans

osCommerce Monkey & Lead Guitarist for "Sparky + the Monkeys" (Album on sale in all good record shops)

 

---------------------------------------

Software is like sex: It's better when it's free. (Linus Torvalds)

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...