Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: The downloadable products directory does


john32

Recommended Posts

I get this message "Warning: The downloadable products directory does not exist: /home/skilsma/public_html/mall2download/. Downloadable products will not work until this directory is valid."

 

I think a "/" is missing somewhere.

I tihink it should be /home/skilsma/public_html/mall2/download/. mall2=where os is stored.

 

Thank you!

Link to comment
Share on other sites

I get this message "Warning: The downloadable products directory does not exist: /home/skilsma/public_html/mall2download/. Downloadable products will not work until this directory is valid."

 

I think a "/" is missing somewhere.

I tihink it should be  /home/skilsma/public_html/mall2/download/. mall2=where os is stored.

 

Thank you!

 

You will find that in your includes/configure.php file

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Thank you.

 

I looked in the configure.php file but I can?t find anything wrong?

 

<?php

/*

  $Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright © 2003 osCommerce

 

  Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://blabla.se');

define('HTTPS_SERVER', 'https://blabla.se');

  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://blabla.se');

define('HTTPS_COOKIE_DOMAIN', 'https://blabla.se');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/mall2/');

define('DIR_WS_HTTPS_CATALOG', '/mall2/');

define('DIR_WS_IMAGES', '/mall2/images/');

define('DIR_WS_ICONS', '/mall2/icons/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

  define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

  define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'skilsma_osc3');

define('DB_SERVER_PASSWORD', 'gf0qvey178');

define('DB_DATABASE', 'skilsma_osc3');

  define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql');

?>

 

 

Can anyone see anything wrong?

Link to comment
Share on other sites

recommendations:

define('HTTP_COOKIE_DOMAIN', 'http://blabla.se');

define('HTTPS_COOKIE_DOMAIN', 'https://blabla.se');

to

define('HTTP_COOKIE_DOMAIN', 'blabla.se');

define('HTTPS_COOKIE_DOMAIN', 'blabla.se');

 

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

to

define('HTTP_COOKIE_PATH', '/mall2/');

define('HTTPS_COOKIE_PATH', '/mall2/');

 

questionable, as this is not normally this way:

define('DIR_WS_IMAGES', '/mall2/images/');

define('DIR_WS_ICONS', '/mall2/icons/');

to

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', 'icons/');

 

i would change this:

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

to:

find your document root path via the admin/tools/server info and search for document root, place here.

Link to comment
Share on other sites

Thank you, it worked. But when I try to download the products it works only if I save the product on my computer, not if I try to open the file immediately. I tryed to zip the file. I typed filename.zip in products attributes. Doesnt work at all.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...