Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Database Import Error


atcshop.com

Recommended Posts

Hi there

 

Very new to osCommerce and trying to set it up for my new domain at: www.atcshop.com

 

Getting stuck early in the installation and getting the following error:

 

Access denied for user: 'atcshop_atcusr@localhost' (Using password: YES)

 

Tried a variety of things, such as using FTP address for DB server etc (but I believe localhost is the correct setting to use)

 

I have created the DB on MYSQL (using Cpanel) and the user and password. I also have assigned ALL priveliges to the user and added the user to the DB.

 

Still no joy!

 

I havent a clue what I am doing wrong. Any suggestions would be most appreciative...

Link to comment
Share on other sites

db host is localhost

 

you need the username and password

 

Thanks for the reply... yet still confused...

 

what username and password do I need. I did create a User which I added to the DB and there I created a username and password.

 

It is something like this (not exactly for security reasons) atcshop_usr and atcshop_pss (in cpanel it automatically assigns your hosting username and an underscore to the username, password and database name)

Link to comment
Share on other sites

Thanks for the reply... yet still confused...

 

what username and password do I need. I did create a User which I added to the DB and there I created a username and password.

 

It is something like this (not exactly for security reasons) atcshop_usr and atcshop_pss (in cpanel it automatically assigns your hosting username and an underscore to the username, password and database name)

 

It sounds like you are doing it correctly. Make sure you have the correct password for the user. If you had a typo when entering it in when you created the user then you would be using the incorrect one. ( that bit me once) Also while localhost is usually correct you may need to use something else. I just installed an osC site on a windows server for a client (for the first and hoppefully last time) and localhost was not what I had to use. You may want to double check with the hosting company

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Hi Chris,

 

sounds like a problem I'd realized, too.

 

My problem was a MySQL-Server newer than version 4.1, which accepts only "new" passwords to authenticate. OsCommerce obviously transmits password the old-style way.

 

To convert the passwort for the user to old-style, log in to the MySQL command line client and type

 

set password for <user>@localhost = OLD_PASSWORD ('<newpassword>')

 

Then try again to establish the test-connection of oscommerce.

 

Hope that helps...

 

Hi there

 

Very new to osCommerce and trying to set it up for my new domain at: www.atcshop.com

 

Getting stuck early in the installation and getting the following error:

 

Access denied for user: 'atcshop_atcusr@localhost' (Using password: YES)

 

Tried a variety of things, such as using FTP address for DB server etc (but I believe localhost is the correct setting to use)

 

I have created the DB on MYSQL (using Cpanel) and the user and password. I also have assigned ALL priveliges to the user and added the user to the DB.

 

Still no joy!

 

I havent a clue what I am doing wrong. Any suggestions would be most appreciative...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...