Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cookie & Checkout Problem


jsb

Recommended Posts

Turn off the 'Force Cookie Use' feature in your osCommerce Control Panel (find it under Configuration). Unless you have a full ssl certificate installed you cannot use this feature.

 

Vger

So here my problem. I can't checkout. When i tryed to checkout its goes to the login page. Even if im already loged in.

 

How can i fix this :)

Link to comment
Share on other sites

Have you changed or set up you configure.php file lately?

 

Sounds like a cookie problem!

 

Also what settings do you have in the sessions?

 

 

Everything is at false.

 

I think i changed i few value cauz i install some mods but that its

 

Here some of my value about cookie in my configure.php

 

define('HTTP_COOKIE_DOMAIN', 'http://www.xgamer.ca/');

define('HTTPS_COOKIE_DOMAIN', 'http://www.xgamer.ca/');

define('HTTP_COOKIE_PATH', 'http://www.xgamer.ca/');

define('HTTPS_COOKIE_PATH', 'http://www.xgamer.ca/');

Link to comment
Share on other sites

Everything is at false.

 

I think i changed i few value cauz i install some mods but that its

 

Here some of my value about cookie in my configure.php

 

define('HTTP_COOKIE_DOMAIN', 'http://www.xgamer.ca/');

define('HTTPS_COOKIE_DOMAIN', 'http://www.xgamer.ca/');

define('HTTP_COOKIE_PATH', 'http://www.xgamer.ca/');

define('HTTPS_COOKIE_PATH', 'http://www.xgamer.ca/');

 

Try changing the both cookie domains to .xgamer.ca

 

And also change both cookie path to '/'

 

This was advice given to me when I was having problems and it seemed to solve it.

 

I was also advised to change the following

 

define('STORE_SESSIONS', 'mysql');

 

mine was empty so I changed it to mysql.

 

These changes worked for me.

Link to comment
Share on other sites

Try changing the both cookie domains to .xgamer.ca

 

And also change both cookie path to '/'

 

This was advice given to me when I was having problems and it seemed to solve it.

 

I was also advised to change the following 

 

define('STORE_SESSIONS', 'mysql');

 

mine was empty so I changed it to mysql.

 

These changes worked for me.

 

Sorry just looked at my post.

 

The cookie path setting I suggested is alright if your store is located in root folder. If you have a catalog folder then change the path to /catalog/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...