Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with linking to products from outside


human

Recommended Posts

Hi All,

 

I am a newbie at Osc, a few weeks ago we bought a SSL-cert (not shared) to our site. And a few days or more after that I was testing the Tell-a-Friend feature and when I tried to click on the product-link I got the this message:

 

***** error, unable to determine page link

 

I have been scanning this forum and found a lot of problems with this message but none that helps me.

 

If I after clicking on that link (Tell-a-friend) and getting that error try to go to the shop, I often cannot click on links who has not cPath in them, e.g. New-products-box and Feature-products-box. I also have problem with Buy-now buttons. But no problem with same product with cPath in link, like Category-box. I get the same error if I try to click on these links.

 

I then have to close down my webbrowser and make a new connection with my site and then every internal link can be just fine, and I will not get the same error. But the external link (Tell-a-friend) will not work and the same error message is sent.

 

If I have a separate web-window open, inside the shop and I click on the external link, it can work sometimes but not always. The same is if I include a cPath in the external link, it will work better. But sometimes I will get the same message.

 

For me it is very hard to trial and error because I am a newbie, but I wunder if it is something to do with Cookies and some add-ins I been trying to change, Featured products, or if its the SSL-certificat or some other configuration?

 

Search engine friendly url is set to False

Force Cookie True

 

Greatful for any input and help.

 

thanks

jane

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."

- Albert Einstein

Link to comment
Share on other sites

Its me again.

 

I think it has something to do with product_info.php file, because everytime when a link from the outside of the shop tries to link to a product with /product_info.php/xxxxx in it, I receive: error, unable to....

 

But if I click within the shop the page is okay, but I cannot reach it from the outside.

 

Any suggestions, what can be wrong in product_info.php?

 

I also have Sts-contrib. installed, if that can be any help.

 

thanks

jane

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."

- Albert Einstein

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...