Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

config.php file problems(i think)


sili213

Recommended Posts

afternoon all, hope i get this situation sorted out somewhat soon.

ive had a working osc setup on a server we use for a little bit, while i tweaked it, built a template, etc. just got the dns changed yesterday, and no matter what i change in the config.php files i keep getting errors. im pretty sure it has to do with paths, heres the error i get on the index page

 

Warning: main(includes/configure.php): failed to open stream: No such file or directory in /home/dv/public_html/includes/application_top.php on line 29 

Warning: main(includes/configure.php): failed to open stream: No such file or directory in /home/dv/public_html/includes/application_top.php on line 29 

Fatal error: main(): Failed opening required 'includes/configure.php' (include_path='/usr/local/lib/php:/usr/lib/php') in /home/dv/public_html/includes/application_top.php on line 29

 

looks like that include path is wrong on the bottom line, but no matter what i do this thing insists on being a pain...i think its funny how you can spend a month pulling your hair out tweaking things that seem next to impossible...then run into a roadblock of a single config file being a pain

 

heres a copy of my /inc/conf.php file

 

 

<?php 
/* 
 osCommerce, Open Source E-Commerce Solutions 
 http://www.oscommerce.com 

 Copyright (c) 2003 osCommerce 

 Released under the GNU General Public License 
*/ 

// Define the webserver and path parameters 
// * DIR_FS_* = Filesystem directories (local/physical) 
// * DIR_WS_* = Webserver directories (virtual/URL) 
 define('HTTP_SERVER', 'http://www.website.com'); // eg, http://localhost - should not be empty for productive servers 
 define('HTTPS_SERVER', 'https://www.website.com'); // eg, https://localhost - should not be empty for productive servers 
 define('ENABLE_SSL', true); // secure webserver for checkout procedure? 
 define('HTTP_COOKIE_DOMAIN', 'www.website.com'); 
 define('HTTPS_COOKIE_DOMAIN', 'www.website.com'); 
 define('HTTP_COOKIE_PATH', 'www.website.com/'); 
 define('HTTPS_COOKIE_PATH', 'www.website.com/'); 
 define('DIR_WS_HTTP_CATALOG', '/'); 
 define('DIR_WS_HTTPS_CATALOG', '/'); 
 define('DIR_WS_IMAGES', 'images/'); 
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); 
 define('DIR_WS_INCLUDES', 'includes/'); 
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); 
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); 
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); 
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); 
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); 

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); 
 define('DIR_FS_CATALOG', '/home/username/public_html/'); 
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); 
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); 

// define our database connection 
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers 
 define('DB_SERVER_USERNAME', 'dbuser'); 
 define('DB_SERVER_PASSWORD', 'dbpass'); 
 define('DB_DATABASE', 'dbname'); 
 define('USE_PCONNECT', 'false'); // use persistent connections? 
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' 
 // CLR 020605 defines needed for Product Option Type feature. 
 define('PRODUCTS_OPTIONS_TYPE_SELECT', 0); 
 define('PRODUCTS_OPTIONS_TYPE_TEXT', 1); 
 define('PRODUCTS_OPTIONS_TYPE_RADIO', 2); 
 define('PRODUCTS_OPTIONS_TYPE_CHECKBOX', 3); 
 define('TEXT_PREFIX', 'txt_'); 
 define('PPRODUCTS_OPTIONS_VALUE_TEXT_ID', 0); //Must match id for user defined "TEXT" value in db table TABLE_PRODUCTS_OPTIONS_VALUES 
?>

 

any help with this would be greatly apriticated

Link to comment
Share on other sites

define('HTTP_COOKIE_PATH', '/');

 

 

define('HTTPS_COOKIE_DOMAIN', 'www.website.com'); //only if you have a full ssl cert installed, ditto

 

define('HTTPS_SERVER', 'https://www.website.com');

 

Also, you can try this (works on some servers)

 

define('HTTP_COOKIE_DOMAIN', 'website.com'

 

define('PPRODUCTS (should there be two p's?)

 

Vger

Link to comment
Share on other sites

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_DOMAIN', 'www.website.com'); //only if you have a full ssl cert installed, ditto

 

define('HTTPS_SERVER', 'https://www.website.com');

 

Also, you can try this (works on some servers)

 

define('HTTP_COOKIE_DOMAIN', 'website.com'

 

define('PPRODUCTS (should there be two p's?)

 

Vger

 

yeah, oddly enough the double P isnt a typo, its part of the option type contribution

 

as far as a full ssl cert installed, we dont have one, we just have a shared ssl certificate that we can access through another url, or through https://thesite

 

tried changing the values but still no luck...also the admin panel hasnt worked since i got the dns up.

 

i also tried to run the install again(without importing a new db of course) but wound up getting the same kind of errors...once i edited application.php and mainpage.php in the install folder it went okay, but still cant get this working with the osc default options it set :(

Link to comment
Share on other sites

define('ENABLE_SSL', false);  //until you use the correct path for your shared ssl

 

Vger

 

doesnt help any, tried that already, and just tried again...this thing is giving me a headache...after all the time it took to get it working right, a simple step like this is killing me lol...always something i guess.

 

im no expert but

 

Fatal error: main(): Failed opening required 'includes/configure.php' (include_path='/usr/local/lib/php:/usr/lib/php') in /home/dv/public_html/includes/application_top.php on line 29

 

does that include path look right? with the : in it? and judging my the error message could it be possible that its looking for includes/configure.php IN that folder, or maybe in /home/dv/public_html/includes/ ? im sure this problem is based on something stupid and small..most likely a single line that im overlooking, but i just ran the install again, and the config file it makes is pretty much the same as the one i have.

 

btw Vger, thanks for trying to help, i really do apriticate it :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...