Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

I see the https:// but have no padlock in IE


k1w1guy

Recommended Posts

My cart is up and runnig. All modules work fine. It's just the SSL cert seems to be missing some paths or something.

 

In IE you will see the https:// but NO padlock. In FireFox you'll see the https:// and a padlock with a red diagonal line through it. What's that all about?

 

Go to ZangoPill.com and click on Create an Account or My Account.

 

Then once I log in from the Login Page and enter the account.php page notice the https has gone again (http://www.zangopill.com/account.php)

 

I called my hosting company and they said the SSL cert is active and set up correctly, and that it must be the code in my .php pages.

 

Below is my includes/configure.php file with the xxxx being username, password and databse name.

 

 

I'm kinda up against the wall on this project. Can anyone bail me out?

 

Thanks,

 

Pete

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.zangopill.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://www.zangopill.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.zangopill.com');

define('HTTPS_COOKIE_DOMAIN', 'www.zangopill.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/content/k/1/w/k1w1guy/html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'mysql.secureserver.net'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxxx);

define('DB_SERVER_PASSWORD', 'xxxx');

define('DB_DATABASE', 'xxxx');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

It's just the SSL cert seems to be missing some paths or something

 

Don't take the word of your host that the full SSL cert is installed correctly. Some support staff don't know a thing apart from what's on the screen in front of them. Make sure that they rebooted the httpd folder, else your intermediate certificate won't be there and your certificate won't be 100% valid.

 

Vger

Link to comment
Share on other sites

create an html file and see if it will secure by going to https: and then your domain and file name

 

Thanks for the info. It seems I can go to any http:// URL in my site a "manually" insert/type the 's' into the URL in the address bar of my brower, turning the URL into an https:// address and it works fine.

 

It's like this on ALL my pages.

 

Go here then insert the 's' after the http and see what I'm saying. It works fine!

Link to comment
Share on other sites

Thanks for the info. It seems I can go to any http:// URL in my site a "manually" insert/type the 's' into the URL in the address bar of my brower, turning the URL into an https:// address and it works fine.

 

It's like this on ALL my pages.

 

Go here then insert the 's' after the http and see what I'm saying. It works fine!

 

 

NO GREAT!!! That's not true. Sorry.

Link to comment
Share on other sites

Don't take the word of your host that the full SSL cert is installed correctly.  Some support staff don't know a thing apart from what's on the screen in front of them.  Make sure that they rebooted the httpd folder, else your intermediate certificate won't be there and your certificate won't be 100% valid.

 

Vger

 

 

I agree. Time for a "whiz up" I'm gettin them on the line now. Thanks Vger.

Link to comment
Share on other sites

have your host reboot the server, see what happens.

 

another coincidence, another starfield SSL certificate .  .

 

 

Beautiful! I'll do it right now.

 

Hey in regards to my previous post... All the ADMIN pages work fine. I'm wondering if it is the OScommerce frames.

 

Go to my ADMIN Page (BE NICE PEOPLE, IT HAS NO PASSWORD, hence my other post.) and insert the 's' behind the http and see for yourself.

 

Pete

Link to comment
Share on other sites

I need help on this same issue... I have the SSL installed correct, but I get not lock in ie and for Firefox I get an x through my lock... Please help.

 

http://www.centeringcorp.com

 

I have set up a test page to see if it works without code and it does work fine

 

https://www.centeringcorp.com/test.html

 

Thanks,

Kevin

Link to comment
Share on other sites

Your certificate is set up correctly, but have you enabled ssl in your configure.php files, as in

 

define('ENABLE_SSL', true);

 

Vger

 

Thanks Vgar, but I do have them set to true. Below is my config file

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.centeringcorp.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://www.centeringcorp.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.centeringcorp.com');

define('HTTPS_COOKIE_DOMAIN', 'www.centeringcorp.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/homepages/35/d97700110/htdocs/centering/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

Link to comment
Share on other sites

ahhhhhhh, the good old double posting . . . . please no double posting of the same question, clutters things up and now i see there have been other posts here.

Link to comment
Share on other sites

in your other post/thread i gave an answer, which stated, you have images which are not being called via the ssl side of the site, thus they must be static and need to be relative. the header and the shop online image for sure . . .

Link to comment
Share on other sites

in your other post/thread i gave an answer, which stated, you have images which are not being called via the ssl side of the site, thus they must be static and need to be relative.  the header and the shop online image for sure . . .

 

Just double checked again...

 

all images are relative

<td background="../images/leftbg.gif" width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="6" cellpadding="2">

<img src="../images/shophead.gif" width="207" height="34">

Link to comment
Share on other sites

Just double checked again...

 

all images are relative

<td background="../images/leftbg.gif" width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="6" cellpadding="2">

    <img src="../images/shophead.gif" width="207" height="34">

 

 

I'd like to thank everyone for there help on this issue! with the help of some great member I found the fix!

 

http://www.oscommerce.com/forums/index.php?showtopic=72486

 

Thanks again!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...