Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Install help: Admin doesn't work but shop does...


HITtheSCENE.com

Recommended Posts

Hey guys,

 

I am having a few problems setting up oscommerce, I followed the instructions to install, but something seems to be up, I think I might have screwed it up somewhere, and wondered if anyone could help me out.

 

I get this error when I try and log into the admin section:

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /homepages/46/d75711124/htdocs/shop/catalog/admin/includes/functions/database.php on line 19

Unable to connect to database server!

 

 

But I am able to view the shop and that seems to be install ok, except for a pink error at the top of the page:

 

http://www.f1action.com/shop/catalog/index.php

 

 

Does anyone know what's gone wrong?

 

Thanks alot for any help :thumbsup:

Dave

Link to comment
Share on other sites

Warning: I am able to write to the configuration file: /homepages/46/d75711124/htdocs//shop/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

Note the double slash after htdocs, problem there.

 

With regard to being unable to connect to admin, you need to go to /catalog/admin/includes/configure.php and scroll down to the bottom and check that you have a name for your database in there (check it against the entry for catalog/includes/configure.php).

 

To remove the 'pink' error you need to ftp to your site and change the file permission for catalog/includes/configure.php to 400 (owner - read only)

 

Vger

Link to comment
Share on other sites

To remove the 'pink' error you need to ftp to your site and change the file permission for catalog/includes/configure.php to 400 (owner - read only)

 

I was able to remove the 2 pink errors I had at the top...however I gave includes/configure.php set to 644. Is having it set to 644 a security risk. Should I change it to 400....and if so, are there any other files/folders I shoud do the same for?

 

Thanks

Link to comment
Share on other sites

Note the double slash after htdocs, problem there.

 

With regard to being unable to connect to admin, you need to go to /catalog/admin/includes/configure.php and scroll down to the bottom and check that you have a name for your database in there (check it against the entry for catalog/includes/configure.php).

 

To remove the 'pink' error you need to ftp to your site and change the file permission for catalog/includes/configure.php to 400 (owner - read only)

 

Vger

 

Hey thanks, I adjusted the admin config file so th date at the bottom was the same, but I still have the same error, should I delete and reinstall the shop?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...