Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Common Error "failed to open stream"


mittoni

Recommended Posts

We have a previous installation of oscommerce installed and working perfectly -- however after trying the current CVS snapshot we are experiencing the same error that several others are experiencing on this forum:

 

OTHER REPORTS:

 

http://www.oscommerce.com/forums/index.php?showtopic=117292&hl=

http://www.oscommerce.com/forums/index.php?showtopic=118647&hl=

http://www.oscommerce.com/forums/index.php?showtopic=120076&hl=

http://www.oscommerce.com/forums/index.php?showtopic=119938&hl=

http://www.oscommerce.com/forums/index.php?showtopic=118475&hl=

 

PROBLEM:

 

After installing the file, ensuring the database is set up and then going to www.yoursite.com/catalog/ the following error is displayed:

 

Warning: main(languages/english.php): failed to open stream: No such file or directory in /home/yoursite/public_html/catalog/install/includes/application.php on line 28

 

Fatal error: main(): Failed opening required 'languages/english.php' (include_path='') in /home/yoursite/public_html/catalog/install/includes/application.php on line 28

 

CLUES:

 

None really, except the "include_path" seems to be different amoungst the various reports on this forum, and the line number is either 22 or 28.

 

If I edit the file application.php and provide the full path the the file languages/english.php then things work fine -- it falls over again later in the web configuration process.

 

Has something changed in the package that requires a path to be set? I can't see where "include_path" is set within the php files and suspect this may be the problem.

 

Any ideas appreciated, I will post any successful contributions.

Link to comment
Share on other sites

are you trying to use the current cvs for production? if i understand correctly, not recommended.

 

i havent tried the cvs as i dont need the 'fun' associated with debugging something.

 

compare the configure.php files with others, also compare the installation files with ms2 and see how much they differ

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...