Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem Integration with 2CO


kikePTY

Recommended Posts

Hi Everybody!

 

I got a problem: My OsCommerce system is working perfect, i place an order using 2CO in the test mode, and after the transaction approval, it passes back to the client area with the link to download the product. It?s fine.

But when i update the 2CO account to my number account and switch to production, it does the transaccion and my credit card is billed, but it doesn?t have a a link or an automatic return back to the client area to download the product and in Os Commerce system doesn?t place any order.

 

I set up the 2CO account pass back YES and i put the url https://mysslsite/myuser/catalog/checkout_success.php and it doesn?t work.

 

Can someone help me please, I cannot put my site in production until i don?t resolved this mistake.

 

Please help me!

 

:thumbsup:

Link to comment
Share on other sites

Hi Everybody!

 

I got a problem: My OsCommerce system is working perfect, i place an order using 2CO in the test mode, and after the transaction approval, it passes back  to the client area with the link to download the product. It?s fine.

But when i update the 2CO account to my number account and switch to production, it does the transaccion and my credit card is billed, but it doesn?t have a a link or an automatic return back to the client area to download the product and in Os Commerce system doesn?t place any order.

 

I set up the 2CO account pass back YES and i put the url https://mysslsite/myuser/catalog/checkout_success.php and it doesn?t work.

 

Can someone help me please, I cannot put my site in production until i don?t resolved this mistake.

 

Please help me!

 

:thumbsup:

 

If you are using the stock 2ckout module there is a problem with it. Look for a thread titled screwed by 2checkout. They changed the way they do things and the old module does not quite work right anymore and there were a couple of fixes in that thread. You might also look in the contributions and see if someone has posted a fix there.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Can someone help me with a possible solution for this. Someone that is using OsCommerce with 2CO new system or can you refer other checkout companies that work without complications with any of the default modules of OsCommerce?

 

Please if someone can help me.

 

Thanks! :thumbsup:

Link to comment
Share on other sites

Can someone help me with a possible solution for this. Someone that is using OsCommerce with 2CO new system or can you refer other checkout companies that work without complications with any of the default modules of OsCommerce?

 

Please if someone can help me.

 

Thanks! :thumbsup:

 

Did you check out the thread I told you about? There is a fix in it and it works, I have used it. You will have to wade though some posts to find it but it is there.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Well that took me all of three minutes to find. There are a few different fixes but I used this one of the sites I worked on

 

2CheckoutFix

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...