Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Random admin error


msheno01

Recommended Posts

Every once in a while when I try to enter the admin section of the website, I get this error:

 

Warning: main(includes/languages/engli): failed to open stream: No such file or directory in /home/mesztekc/public_html/admin/includes/application_top.php on line 136

Warning: main(includes/languages/engli): failed to open stream: No such file or directory in /home/mesztekc/public_html/admin/includes/application_top.php on line 136

Fatal error: main(): Failed opening required 'includes/languages/engli' (include_path='.:/usr/local/lib/php') in /home/mesztekc/public_html/admin/includes/application_top.php on line 136

 

I have tried looking around but can't figure out the problem.

 

Here is the part of application_top.php that I think is relevant:

 

// include the language translations
 require(DIR_WS_LANGUAGES . $language . '.php');
 $current_page = basename($PHP_SELF);
 if (file_exists(DIR_WS_LANGUAGES . $language . '/' . $current_page)) {
   include(DIR_WS_LANGUAGES . $language . '/' . $current_page);
 }

// define our localization functions
 require(DIR_WS_FUNCTIONS . 'localization.php');
define('FILENAME_VISITORS', 'visitors.php');
define('TABLE_VISITORS', 'visitors');

// Include validation functions (right now only email address)
 require(DIR_WS_FUNCTIONS . 'validations.php');

 

Thanks

Moneer

Link to comment
Share on other sites

no, that is how it is. That is the part that is driving me crazy.

It is like the variable changed.

I would be working on admin just fine then all of a sudden this happens. All I get is this page.

 

I have to wait several minutes, 20 minutes for me to be able to log on again.

Link to comment
Share on other sites

I have been with the same web hosting for over a year now and never had a problem with mysql session storage

 

Perhaps the database got to be too large for what your host allows. Ask them if mysql is set to max on their servers.

 

Vger

Link to comment
Share on other sites

if still problems, may be time to move to a host which supports what you need done.

also, turn off portions of the logging and sessions you do not need in the store admin

Link to comment
Share on other sites

I will try to disable some logging but as far as I know, all the logging are disabled.

 

My host allows me a sql database as large as my space allows and I have alot of space left.

I will however ask if they have any idea why this is happening. By the way the hosting company is ipowerweb

From my experience they are pretty good

 

THanks

Moneer

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...