Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

CHMOD in configure.php (How edit?)


Guest

Recommended Posts

I not speak english,

But, help me don't ask... (sorry)

 

I look this message in my index.php:

 

Warning: I am able to write to the configuration file: /home/midialab/public_html/shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

Please help me,

 

 

Tanks.

Link to comment
Share on other sites

use your host cpanel file manager and set the file permissions on the configure.php file to 644

or

use your ftp program, when attached to the site, right click on the file and set permissions to 644

Link to comment
Share on other sites

use your host cpanel file manager and set the file permissions on the configure.php file to 644

or

use your ftp program, when attached to the site, right click on the file and set permissions to 644

 

no ok... :(

no, no... :huh:

Link to comment
Share on other sites

use your host cpanel file manager and set the file permissions on the configure.php file to 644

 

Warning: At least a few versions of cPanel have a flaw in their file manager that doesn't properly change a file's permissions. For this reason exactly, I recommend using an FTP client that allows you to change permissions. If you're a Windows user, try FileZilla or WS_FTP. I believe that both of those allow you to set file permissions.

 

-jared

Link to comment
Share on other sites

Warning:  At least a few versions of cPanel have a flaw in their file manager that doesn't properly change a file's permissions.  For this reason exactly, I recommend using an FTP client that allows you to change permissions.  If you're a Windows user, try FileZilla or WS_FTP.  I believe that both of those allow you to set file permissions.

 

-jared

You could also use SmartFTP or an online FTP tool such as net2tfp.com.

Link to comment
Share on other sites

I used WS_FTP to set CHMOD to 644 and still get the same error! - Is there another setting I missed?

I am running the server in without SSL to test our ability to use the cart before going live. Will this effect the error that I am getting? - Thank You

Link to comment
Share on other sites

Did you chmod the right file? You want catalog/includes/configure.php . No, SSL should not affect that particular error.

 

FWIW, my configure.php is set to 444.

 

-jared

Link to comment
Share on other sites

You guy's are great and quick! thanks for the assistance

 

Don't give us too much credit. You just happened to catch the both of us while we were paying attention to the election poll results. :)

 

-jared

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...