Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals is disabled in php.ini


Johnny?

Recommended Posts

Register_globals is disabled in php.ini on my web server, my web host has informed me that they won't enable it on their windows servers.

 

I have been told that i would have to move my domain to a linux server and i really don't want to have to do this as i have things set up nicely atm.

 

Are there specific reasons why an ISP wouldn't enable this on a windows server? (security etc.)? or are they just being jobsworths? i would like to take a valid arguement to them.

 

Is there any coding solution or trick to resolve this issue? I have tried placing a command in the .htaccess file in the root of the server to turn the variable on but to no avail, so this is not an option.

 

I read in a post that a version will be released soon that doesn't require the 'register_globals' in 'php.ini' to be enabled? is this true? (I'm using the latest version of osCommerce as of today.)

 

 

Many thanks

Link to comment
Share on other sites

  • 2 weeks later...
http://www.oscommerce.com/community/contri...egister_globals

 

:D  :rolleyes:

 

lesson: always search the contributions first!  :blush:

 

 

While that does provide a solution it really does not answer his questions.

 

Also surely there must be a premodded versioon available for download somewhere.

 

I am sure I am not the first to think of it.

 

KM

Link to comment
Share on other sites

Hi !

 

My host disabled registered globals last night.

found out this morning by the usual error message.

 

I've used a .htaccess file to enable it and now the catalog works.

 

 

But I cannot admin my site !

 

admin\index.php will not load !

 

 

Fatal error: Cannot re-assign $this in /home/babyish/public_html/catalog/admin/includes/classes/upload.php on line 31

 

it says $this = null; on line 31

 

Can anyone help ?

 

Thxs

 

Ramesh

Special Effects / 3d + Flash

Link to comment
Share on other sites

Comment out

 

//$this = null;

 

This is a known PHP5 incompatibility with osCommerce. You won't see any problems by commenting this out.

 

HTH

Tom

 

YES ! it WORKS !

 

just comment it out and voila !

 

 

Many Thanks !

 

Was very HELPFUL !

Special Effects / 3d + Flash

Link to comment
Share on other sites

While that does provide a solution it really does not answer his questions.

 

Also surely there must be a premodded versioon available for download somewhere.

 

I am sure I am not the first to think of it.

 

KM

 

well i have premodded and made a .zip of the latest fix, built in to all files, if anyone wants it? msn or email me [email protected].

 

Ramesh i tried to force enable globals but it just wouldn't work, going through the whole mod was the only fix for me but it did work! :D

Link to comment
Share on other sites

I had a similar problem and fixed it by installing the same patch. However I find that the admin panel has real brain damage, where sessioning is concerned. I get the following error when attempting to navigate the admin pages on my new installation:

(!) Warning: Failed opening http://.../reviews.php for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0

 

The host is a virtual Win2k3 running php 4.2.3 as ISAPI. The catalog works beautuifully, with no errors. Can anyone tell me what is causing this issue? The is a new launch that will be vending 30,000 products it sort of needs an working admin panel. ;)

 

Fred

Link to comment
Share on other sites

I sent a mail to my provider if he can set the register_globals on but he told me that it will be a security problem so that they wont set it on. :'(

 

Is there no other way to fix that problem?

Link to comment
Share on other sites

Warning: Failed opening http://.../reviews.php for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0

 

This is also (usually) fixed by commenting out $this to //$this in the upload.php file.

 

I sent a mail to my provider if he can set the register_globals on but he told me that it will be a security problem

 

Having register_globals=On does pose a potential security problem. Windows servers are so insecure anyway, requiring almost daily patching to try and keep hackers out. If your hosting company uses Linux/Unix servers and have fully updated firewalls then it shouldn't pose a problem to your site. You can try setting register_globals=On by the use of .htaccess, but my guess is that your hostig provider would now expect you to try and do that and will monitor your site. Best advice - find a hosting company that allows register_globals=On.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...