Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Blank page index.php


colombia

Recommended Posts

Hello, I installed oscommerce once and everything was fine, I edited the index.php file and uploaded with the changes, now the site www.webypunto.com/catalog only shows and empty page, no erros. This is the code that is uploading,

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<HTML><HEAD>

<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>

<BODY></BODY></HTML>

 

when I open the index.php file on notepad it shows the real thing.

 

What to do?. As I said I already reinstalled.

TIA

Link to comment
Share on other sites

what did you edit in the index.php?

copy an original index.php over the top and what happens?

 

I tryed to change the following text on the original index.php,

 

?php

/*

$Id: index.php,v 1.3 2003/07/08 16:56:04 dgw_ Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

define('TEXT_MAIN', 'Esta es la configuración por defecto......................................

 

And the actual file uploaded is the original. located at /public_html/catalog/includes/languages/espanol

 

Could it be that the sql server is down or misconfigured? I asked the hosting company and one support guy said they were having troubles with sql at some servers, but another suppor guy told my that the server where my website is hosted is fine.

 

I copyed the original twice over the edited one but still a blank html page shows, it seems the index.php is not loading at all.

 

Thanks

Link to comment
Share on other sites

editing the language file is shown on the front page, as pointing to includes/languages/english/index.php

 

 

I fix it the hard way, I erased every thing from the server as I didn?t see any option to uninstall. Now I am back from the beginning, In my front page it states the following

this text can be change editing the file

includes/languages/[language]/default.php. However I don?t see any default.php file on such directori, all I see in there are three dirctories one English, another German and Spanish followed by each laguage .php file

 

Thanks

Link to comment
Share on other sites

You go to includes/lanaguages/english/, and the file to edit is index.php. Don't use the osCommerce file manager to edit the page, download the page, edit it in a plain text editor (such as Notepad) and then upload it again. Don't use an editor such as WordPad because this includes hidden text formatting, and wil screw things up for you.

 

Vger

Link to comment
Share on other sites

You go to includes/lanaguages/english/, and the file to edit is index.php.  Don't use the osCommerce file manager to edit the page, download the page, edit it in a plain text editor (such as Notepad) and then upload it again.  Don't use an editor such as WordPad because this includes hidden text formatting, and wil screw things up for you.

 

Vger

 

Initial success, my front page is in spanish by default so I downloaded a copy of it to the hard drive and open it in Notepad and edited as Vger suggested, then I renamed the original for safety includes/languages/spanish index.php to index1.php, I did a refresh on the browser and of course didn?t see the initia page since the index.php was rename. Then I uploaded the edited index.php and did a refresh again and Voila! it took the small change I made. Thanks I will try customizing more my store.

Link to comment
Share on other sites

Now I am facing this message at the botton of my frontpage

Fatal error: main(): Failed opening required 'includes/counter.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/webypunt/public_html/catalog/includes/footer.php on line 13

 

I tried to overwrite original files to these destinations "/includes but still not results, I guess I could keep customizing while I find a fix to it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...