Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

please help with header code


imaaxx

Recommended Posts

here is the code for my header all i have is one GIF file align left and align right for the advanced search box:

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr class="header">
   <td valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'directory.gif', 'Directory.com') . '</a>'; ?></td>
 <td valign="middle" align="right"><?php echo tep_draw_form('advanced_search', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get"') ?>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_hidden_field('search_in_description','1') . tep_draw_input_field('keywords', '', 'size="10" maxlength="30" style="width: ' . (BOX_WIDTH+1) . 'px"')  ?></td>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo BOX_ADVSEARCH_CAT ?></td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_pull_down_menu('categories_id', tep_get_categories(array(array('id' => '', 'text' => BOX_ADVSEARCH_ALLCAT)))) ?></td>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><left><?php echo tep_image_submit('button_search_small.gif', Search) . '</a>'; ?></td>
 </tr>
</table>

 

everything appears on the page ok the only thing is the search will not return any results. this is what it says:

 

At least one of the fields in the search form must be entered.

 

Could someone please take a look at this and see what is wrong?

 

thanks

Link to comment
Share on other sites

here is the code for my header all i have is one GIF file align left and align right for the advanced search box:

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
?<tr class="header">
? ?<td valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'directory.gif', 'Directory.com') . '</a>'; ?></td>
?<td valign="middle" align="right"><?php echo tep_draw_form('advanced_search', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get"') ?>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_hidden_field('search_in_description','1') . tep_draw_input_field('keywords', '', 'size="10" maxlength="30" style="width: ' . (BOX_WIDTH+1) . 'px"') ??></td>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo BOX_ADVSEARCH_CAT ?></td>
<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_pull_down_menu('categories_id', tep_get_categories(array(array('id' => '', 'text' => BOX_ADVSEARCH_ALLCAT)))) ?></td>
<td class="infoBoxContents" valign="middle" colspan="1"> </td>
<td class="infoBoxContents" valign="middle" colspan="1"><left><?php echo tep_image_submit('button_search_small.gif', Search) . '</a>'; ?></td>
?</tr>
</table>

 

everything appears on the page ok the only thing is the search will not return any results. this is what it says:

 

At least one of the fields in the search form must be entered.

 

Could someone please take a look at this and see what is wrong?

 

thanks

Any Ideas?

Link to comment
Share on other sites

Any Ideas?

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr class="header">

<td valign="bottom"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'directory.gif', 'Directory.com') . '</a>'; ?></td>

<td valign="middle" align="right"><?php echo tep_draw_form('advanced_search', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get"') ?>

<td class="infoBoxContents" valign="middle" colspan="1"> </td>

<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_hidden_field('search_in_description','1') . tep_draw_input_field('keywords', '', 'size="10" maxlength="30" style="width: ' . (BOX_WIDTH+1) . 'px"') ?></td>

<td class="infoBoxContents" valign="middle" colspan="1"> </td>

<td class="infoBoxContents" valign="middle" colspan="1"><?php echo BOX_ADVSEARCH_CAT ?></td>

<td class="infoBoxContents" valign="middle" colspan="1"><?php echo tep_draw_pull_down_menu('categories_id', tep_get_categories(array(array('id' => '', 'text' => BOX_ADVSEARCH_ALLCAT)))) ?></td>

<td class="infoBoxContents" valign="middle" colspan="1"> </td>

<td class="infoBoxContents" valign="middle" colspan="1"><left><?php echo tep_image_submit('button_search_small.gif', Search) . '</a>'; ?></td>

</tr>

</table>

 

I think I should read middle not bottom

( WARNING )

I think I know what Im talking about.

BACK UP BACK UP BACK UP BACK UP

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...