Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New Installation Issue


Guest

Recommended Posts

I am brand new to this product and I am not technically inclined but know my way around. I keep getting this error and I am lost what to do next.

 

New Installation

 

osCommerce Configuration

 

The following error has occurred:

 

 

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /home/virtual/site239/fst/var/www/html/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/virtual/site239/fst/var/www/html/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

If chmod 706 does not work, please try chmod 777.

 

If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created.

 

PLEASE HELP.

Link to comment
Share on other sites

I am brand new to this product and I am not technically inclined but know my way around.  I keep getting this error and I am lost what to do next. 

 

New Installation

 

osCommerce Configuration

 

The following error has occurred:

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /home/virtual/site239/fst/var/www/html/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/virtual/site239/fst/var/www/html/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

If chmod 706 does not work, please try chmod 777.

 

If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created.

 

PLEASE HELP.

 

 

You're being asked to connect to your store directory via FTP or directly on your server and change the file permissions to the numbers directed.

 

If you have an FTP program, go into your webspace, find your store and drill down to /home/virtual/site239/fst/var/www/html/catalog/includes/ first. Right-click the configure.php file you see in that directory and look for an option like "set permissions" or "change attributes" or "chmod" (every FTP prog is different) and set the permissions number to 706.

 

Do the same for the second file. If you get the same error, try again with both files but change the number to 777. You're changing the nature of the files so that the store can perform operations with them.

 

By default your web files have a low level of allowable access so people from the Interweb don't mess with them. In some cases like this one, you have to up the permission levels so that a program can access / execute / write to the files which are normally locked out for safety reasons.

Link to comment
Share on other sites

How do you know this stuff. I am going to try it and by the way, I lvoed your website. And the pictures.

 

 

You're being asked to connect to your store directory via FTP or directly on your server and change the file permissions to the numbers directed.

 

If you have an FTP program,  go into your webspace, find your store and drill down to /home/virtual/site239/fst/var/www/html/catalog/includes/ first. Right-click the configure.php file you see in that directory and look for an option like "set permissions" or "change attributes" or "chmod" (every FTP prog is different) and set the permissions number to 706.

 

Do the same for the second file. If you get the same error, try again with both files but change the number to 777. You're changing the nature of the files so that the store can perform operations with them.

 

By default your web files have a low level of allowable access so people from the Interweb don't mess with them. In some cases like this one, you have to up the permission levels so that a program can access / execute / write to the files which are normally locked out for safety reasons.

Link to comment
Share on other sites

I got Filezilla and when I get to the drill down directory I do not see the configure.php file. Also where do I get the option for change on Filezilla.

Link to comment
Share on other sites

I got Filezilla and when I get to the drill down directory I do not see the configure.php file.  Also where do I get the option for change on Filezilla.

 

Can't help you with the missing file other than to tell you to check your paths carefully. The change option in Filezilla: right-click the file you want to change permissions on and select "File Attributes".

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...