Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

exec() disabled message on backup


bjraybould

Recommended Posts

I got the error message below when backing up my database.

 

I checked the knowledge base for backup, and set the permissions of 777 on the file /home/virtua38/www/artcourses/admin/backups directory

 

ERROR MESSAGE RECEIVED:

 

Warning: exec() has been disabled for security reasons in /home/virtua38/public_html/artcourses/admin/backup.php on line 147

 

Warning: Cannot modify header information - headers already sent by (output started at /home/virtua38/public_html/artcourses/admin/backup.php:147) in /home/virtua38/public_html/artcourses/admin/includes/functions/general.php on line 18

 

any ideas please?

thank you

Barry

Link to comment
Share on other sites

Warning: Cannot modify header information - headers already sent by (output started at /home/virtua38/public_html/artcourses/admin/backup.php:147) in /home/virtua38/public_html/artcourses/admin/includes/functions/general.php on line 18

 

Hi Barry,

 

I am not sure of the backup error as I never had that problem before but I just fixed that error as quoted above.

 

I will be guessing your using cPanel with your host right?

 

Go to those two files and at the VERY bottom, delete all the blank spaces below the ending >

 

cPanel has a habit where it enters space beneath them and that is what it is screwing up.

 

Remember JUST the blank spaces beneath it and you should ALWAYS copy your files BEFORE editting them if anything goes wrong.

 

Do that and get back to me if it's working or not.

 

Shane

Link to comment
Share on other sites

Hi Barry,

 

I am not sure of the backup error as I never had that problem before but I just fixed that error as quoted above.

 

I will be guessing your using cPanel with your host right?

 

Go to those two files and at the VERY bottom, delete all the blank spaces below the ending >

 

cPanel has a habit where it enters space beneath them and that is what it is screwing up.

 

Remember JUST the blank spaces beneath it and you should ALWAYS copy your files BEFORE editting them if anything goes wrong.

 

Do that and get back to me if it's working or not.

 

Shane

 

 

Hi Shane

thanks for the reply, but it did not fix the problem.

 

I still get this message:

 

Warning: exec() has been disabled for security reasons in /home/virtua38/public_html/catalog/admin/backup.php on line 147

 

Warning: Cannot modify header information - headers already sent by (output started at /home/virtua38/public_html/catalog/admin/backup.php:147) in /home/virtua38/public_html/catalog/admin/includes/functions/general.php on line 18

 

 

fyi line 47 in backup.php is: exec(LOCAL_EXE_GZIP . ' ' . DIR_FS_BACKUP . $backup_file);

 

fyi line 18 in general.php is:

header('Location: ' . $url);

 

the context is:

function tep_redirect($url) {

global $logger;

 

header('Location: ' . $url);

 

Any more ideas? This is the application raw out of Fantastico installed through cPanel.

so I have made no modifications on this installation.

 

thanks

Barry

Link to comment
Share on other sites

Hi Shane

thanks for the reply, but it did not fix the problem.

 

I still get this message:

 

Warning: exec() has been disabled for security reasons in /home/virtua38/public_html/catalog/admin/backup.php on line 147

 

Warning: Cannot modify header information - headers already sent by (output started at /home/virtua38/public_html/catalog/admin/backup.php:147) in /home/virtua38/public_html/catalog/admin/includes/functions/general.php on line 18

  fyi line 47 in backup.php is:            exec(LOCAL_EXE_GZIP . ' ' . DIR_FS_BACKUP . $backup_file);

 

fyi line 18 in general.php is:

    header('Location: ' . $url);

 

the context is:

function tep_redirect($url) {

    global $logger;

 

    header('Location: ' . $url);

 

Any more ideas?  This is the application raw out of Fantastico installed through cPanel.

so I have made no modifications on this installation.

 

thanks

Barry

 

...... one more piece of information. I got the above error when choosing the option to use GZIP, and download the backup, rather than storing the backup on the server side.

I did not get the error when backing up and storing on the server, or when downloading and not using GZIP. So it seems that the problem lies with GZIP

 

Any ideas why there is a problem with GZIP?

Link to comment
Share on other sites

In my opinion your GZIP problem lies with...

Warning: exec() has been disabled for security reasons

You should contact your host and ask them.

Based on the error above I don't think it's a osCommerce thing at all.

 

HTH,

Robert

Link to comment
Share on other sites

In my opinion your GZIP problem lies with...

 

You should contact your host and ask them.

Based on the error above I don't think it's a osCommerce thing at all.

 

HTH,

Robert

 

thanks Robert, I'll try contacting them. By the way I looked at your site and liked what I saw. I like the clean very simple and uncluttered user interface and the good content. Both are the key to a successful customer interaction. (Flashy interfaces are usually counter productive). Anyway, nice work.

 

regards

Barry

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...