Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ADMIN PANEL!! HELP


southpoleZero

Recommended Posts

i dont understand it. can someone help me?

 

 

Warning: main(includes/application_top.php): failed to open stream: No such file or directory in /usr/export/www/vhosts/funnetwork/hosting/southpolezero/catalog/admin/index.php on line 13

 

Fatal error: main(): Failed opening required 'includes/application_top.php' (include_path='.:') in /usr/export/www/vhosts/funnetwork/hosting/southpolezero/catalog/admin/index.php on line 13

Link to comment
Share on other sites

is this a new install? how did you do the install? if no data in there you are worried about, go back thru the install, following the procedure in the knowledge base.

Link to comment
Share on other sites

i dont understand it. can someone help me?

Warning: main(includes/application_top.php): failed to open stream: No such file or directory in /usr/export/www/vhosts/funnetwork/hosting/southpolezero/catalog/admin/index.php on line 13

 

Fatal error: main(): Failed opening required 'includes/application_top.php' (include_path='.:') in /usr/export/www/vhosts/funnetwork/hosting/southpolezero/catalog/admin/index.php on line 13

 

 

Hi

I have exactly the same error. In my PC is working fine but not in the Web. I?m using windows server. The other admin option configuration work fine, the only problem is with modules

 

Regards

Carlo

Link to comment
Share on other sites

Hi

 

Ok

 

Open your Admin/includes/configure.php file. You should have a load of paths for your includes, modules ect. If the are not there, put them in.

 

 define('HTTP_SERVER', 'http://www.yoursite.com/'); // eg, http://localhost or - https://localhost should not be NULL for productive servers
?define('HTTP_CATALOG_SERVER', 'http://www.yoursite.uk.com/');
?define('HTTPS_CATALOG_SERVER', 'https://www.yoursite.com/');
?define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
?define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
?define('DIR_WS_ADMIN', 'admin/');
?define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
?define('DIR_WS_CATALOG', '/catalog/');
?define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
?define('DIR_WS_IMAGES', 'images/');
?define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
?define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
?define('DIR_WS_INCLUDES', 'includes/');
?define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
?define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
?define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
?define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
?define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
?define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
?define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
?define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
?define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
?define('DIR_FS_BACKUP', 'backups/');

 

Mines less than perfect but all of your define's should be in this file. Sometimes removing the "/" infront of the paths helps.

 

e.g. "/includes/" changes to "includes/ "

 

Hope that helps

 

Toby

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...