Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

error: FATAL ERROR: register_globals is disabled


sjoerd

Recommended Posts

I have copied the OsCommerce files to the webserver's doc root (Apache 2). But i get stuck on the next step: every PHP file i try to call from the browser (to try to get to the webbased configuration) results in the following error: FATAL ERROR: register_globals is disabled in php.ini, please enable it!

I have tried to change this setting in th php.ini (set it to on) but no results.

It seems to be a php error, so might have made a mistale when installing php but how to check?

Link to comment
Share on other sites

Two things

 

1. When you set register_globals to 'on' in the php.ini file, did you delete the semi-colon and the blank space in front of it, as in

 

; register_globals = On (wrong)

register_globals = On (right)

 

Also, check to see if you have any other php.ini files on your computer, as you may have more than one. If you find others set register_globals=on in all of them.

 

Vger

Link to comment
Share on other sites

Two things

 

1.  When you set register_globals to 'on' in the php.ini file, did you delete the semi-colon and the blank space in front of it, as in

 

; register_globals = On (wrong)

register_globals = On (right)

 

Also, check to see if you have any other php.ini files on your computer, as you may have more than one.  If you find others set register_globals=on in all of them.

 

Vger

--------------------------------------------------

i'm so stupid! Indeed, i did not remove the semicolon!

But unfortunetaly when i did change it OsCommerce still complains that register_globals is disabled. I have no other php.ini files on my system, just the one in the winnt directory.

Link to comment
Share on other sites

Just to make sure, create a small php file phpinfo.php that contains

 

<?php

phpinfo()

?>

 

and the point your browser at it and run it. Look for the "Path to php.ini" entry in the PHP section to triple check you are editing the correct ini file. If its pointing to a non-existant file then PHP will use default settings and globals will probably be set off.

 

HTH

Tom

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...