Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Database Crossover


Biomix

Recommended Posts

Hello all,

 

I have been recently shown that a newer installed store on a server has been randomly showing the categories from another store on the same server. They each have different domains, different logins for mysql, different everything. There is no trace of the other store in the store with the problem.

 

Here is the site having the issues: https://shell4.tdl.com/~hardcore/products/

There should only be 3 categories, "Hats" "Mens Apparel" and "Womens Apparel"

This is the site that is treading on it: https://shell4.tdl.com/~gpdesign/catalog/

This one has a lot more categories.

 

What could possibly be doing this, and is there a way to correct it?

 

Thanks...

-=Biomix

Link to comment
Share on other sites

Hello all,

 

I have been recently shown that a newer installed store on a server has been randomly showing the categories from another store on the same server.  They each have different domains, different logins for mysql, different everything.  There is no trace of the other store in the store with the problem.

 

Here is the site having the issues:  https://shell4.tdl.com/~hardcore/products/

  There should only be 3 categories, "Hats" "Mens Apparel" and "Womens Apparel"

This is the site that is treading on it: https://shell4.tdl.com/~gpdesign/catalog/

  This one has a lot more categories.

 

What could possibly be doing this, and is there a way to correct it?

 

Thanks...

-=Biomix

 

It is a sessions issue,. Best fix is to change the following line in both your configure.php files

 

define('STORE_SESSIONS', ' '); // leave empty '' for default handler or set to 'mysql'

 

To

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

It is a sessions issue,. Best fix is to change the following line in both your configure.php files

 

define('STORE_SESSIONS', ' '); // leave empty '' for default handler or set to 'mysql'

 

To

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

That is already set. I have noticed that if there is no session id and it is going through https, that it will do it. If you go through the www, non-secure, it does fine for the entire session.

 

Either way, how is it getting info from a database that it doesn't have the login/password to?!?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...