Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Look to the future - PHP5


Marc_J

Recommended Posts

Hi,

 

I see from this thread that MS-2 will not be compatible with PHP5.

 

I'm currently working on 4 osCommerce powered sites, some of which are heavily modified (one with over 20 contribs), and just want to know - will the upgrade to PHP5 (i.e. MS-3) be an easy one for such sites, or a headache?

 

I haven't used osCommerce before so have no experience upgrading from one release to another - what does it typically involve? Am I worrying for no reason?

 

I guess I just need some reassurance! I don't see any point in continuing development of these sites if I'll need to seriously delve into them soon (my host is upgrading ASAP).

 

Congrats on a great product btw - I'm fairly new to it but finding my way around!

Link to comment
Share on other sites

We will make sure the MS-3 code works with PHP5... we wont fix any problems with contributions that you may have installed however.

 

We will also provide a DB upgrade where possible to make the MS-2 database MS-3 compatible... although if the contributions you have installed modify the database which conflicts with our upgrader you may have to spend some time troubleshooting.

Mark Evans

osCommerce Monkey & Lead Guitarist for "Sparky + the Monkeys" (Album on sale in all good record shops)

 

---------------------------------------

Software is like sex: It's better when it's free. (Linus Torvalds)

Link to comment
Share on other sites

  • 2 weeks later...
We will make sure the MS-3 code works with PHP5... we wont fix any problems with contributions that you may have installed however.

 

We will also provide a DB upgrade where possible to make the MS-2 database MS-3 compatible... although if the contributions you have installed modify the database which conflicts with our upgrader you may have to spend some time troubleshooting.

 

 

I haven't been back here for some time, but I came-a-running when I got a notification from my Host saying that they have started testing PHP5.

 

I'm guessing that by now later versions of osCommerce are compatible with PHP5 but I'm still using 2.2 (I know I should upgrade :blush: ) but whats the best path for me?? (is there any hope for me :D )

 

Steve Richards

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...