Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Manufacturer logo


Edze

Recommended Posts

Hello,

 

I just started my webshop with osCommerce. I cannot manage to display the manufacturer's logo when selecting a manufacturer in the left column. The same logo does display fine when going to the category.

For example: choosing Fuji digital cameras shows logo to the right of the text This is what we have...

Selecting manufacturer Fuji in the left column does not display that logo.

Who knows what I have done wrong here? :(

 

Please visit De Boer Digital Storages

 

 

With kind regards,

 

Edze de Boer

De Boer Digital Storages

Link to comment
Share on other sites

the code for index.php gives a categories image and a manufacturers image depending on selection.

 

A view source shows no image associated with the manufacturers image however there is an image associated with the category

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

the code for index.php gives a categories image and a manufacturers image depending on selection.

 

A view source shows no image associated with the manufacturers image however there is an image associated with the category

 

 

Hello Steve,

 

Please forgive me, I don't understand what you mean by this.

I just started learning php three weeks ago, when I started with oscommerce....

 

I am sure that the secret is in one of the php files, I cannot remember having changed that particular item. The only thing I did was correcting some translation errors in the dutch files. Now I see the same error in all chosen languages.

 

Can you please explain me, what I have to change to make the logo work?

 

With kind regards,

Edze

Link to comment
Share on other sites

in admin under catalog and then under manufacturers you can edit the manufacturer and state the image to be used by the manufacturer, I think at present you have only stated the image to be used for the category.

 

It relates to this bit of code in index.php

// Get the right image for the top-right
? ?$image = DIR_WS_IMAGES . 'table_background_list.gif';
? ?if (isset($HTTP_GET_VARS['manufacturers_id'])) {
? ? ?$image = tep_db_query("select manufacturers_image from " . TABLE_MANUFACTURERS . " where manufacturers_id = '" . (int)$HTTP_GET_VARS['manufacturers_id'] . "'");
? ? ?$image = tep_db_fetch_array($image);
? ? ?$image = $image['manufacturers_image'];
? ?} elseif ($current_category_id) {
? ? ?$image = tep_db_query("select categories_image from " . TABLE_CATEGORIES . " where categories_id = '" . (int)$current_category_id . "'");
? ? ?$image = tep_db_fetch_array($image);
? ? ?$image = $image['categories_image'];
? ?}

from this bit of code you will see that if the id is a categories_id then the image is a categories_image however if the id is a manufacturers_id then the image is a manufacturers_image

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

Hi Steve,

 

Of course, my mistake :'(

 

I took a look at my list of manufacturers and there were no logos yet.

I will never forget this again......

 

Thanks for your help, with kind regards,

 

Edze

 

 

in admin under catalog and then under manufacturers you can edit the manufacturer and state the image to be used by the manufacturer, I think at present you have only stated the image to be used for the category.

 

It relates to this bit of code in index.php

// Get the right image for the top-right
? ?$image = DIR_WS_IMAGES . 'table_background_list.gif';
? ?if (isset($HTTP_GET_VARS['manufacturers_id'])) {
? ? ?$image = tep_db_query("select manufacturers_image from " . TABLE_MANUFACTURERS . " where manufacturers_id = '" . (int)$HTTP_GET_VARS['manufacturers_id'] . "'");
? ? ?$image = tep_db_fetch_array($image);
? ? ?$image = $image['manufacturers_image'];
? ?} elseif ($current_category_id) {
? ? ?$image = tep_db_query("select categories_image from " . TABLE_CATEGORIES . " where categories_id = '" . (int)$current_category_id . "'");
? ? ?$image = tep_db_fetch_array($image);
? ? ?$image = $image['categories_image'];
? ?}

from this bit of code you will see that if the id is a categories_id then the image is a categories_image however if the id is a manufacturers_id then the image is a manufacturers_image

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...