Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Fixed BUY NOW issue and PRODUCT NEW!!


tektek

Recommended Posts

Hey, Well...after hours and hours of playing with this and that I just simply uploaded my original

 

/catalog/includes/application_top.php

 

/catalog/includes/modules/product_listing.php

 

/catalog/product_review_info.php

 

/catalog/products_new.php

 

files and overwrote the other ones.

 

I know that in some application_top.php in the line "'case 'buy now' :" all the $HTTP_POST_VARS ( if you have that ) should be changed $HTTP_GET_VARS

 

So check that out...Also other stuff I reconfiged :

 

In /catalog/includes/configure.php :

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://SSLprovider.host.com/~yoursite'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'yourdomain.com');

define('HTTPS_COOKIE_DOMAIN', 'SSLprovider.host.com/~yoursite');

define('HTTP_COOKIE_PATH', '/yourshoproot/');

define('HTTPS_COOKIE_PATH', '/~yoursite/yourshoproot/');

define('DIR_WS_HTTP_CATALOG', '/yourshoproot/');

define('DIR_WS_HTTPS_CATALOG', '/yourshoproot/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

*NOTE* My host provider uses /~ for username, yours might use /! or /yoursite.com so make sure you have it right.

 

Next step :

At the bottom of the configure.php file you'll see this *thnx pdxhairball for this part*

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

Change to

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

Now our final step:

These are the Session settings I have in the ADMIN section:

 

Force Cookie Use False

Check SSL Session ID True

Check User Agent False

Check IP Address False

Prevent Spider Sessions True

Recreate Session False

 

DONE!!

 

Follow all these steps, if you have modified any of the files above just overwrite them fresh and remod them if need be. Anyways hope this works for you because it works for me after hours of playing around with it I figured it out :) Maybe we wont see any more posts about this problem again, post and let me know if it works for you or not.

 

Good luck guys!

 

-tektek

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...