Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

creating account page


lbcabe

Recommended Posts

The Problem - On the main index.php page, the links "log yourself in" and "create an account" seem to go to pages that are not in my web host directory. When I look in it, they are actually there but for some reason won't load. I then checked the actual URL and put the exact one in and would get the appropriate screen. The link that corresponds to the above mentioned contain an "s" in http. It looks like this...

https://yoursitename.com/login.php.

If I take the "s" away, I get to the right site and everything works fine. Can someone please tell me where I can fix this so that it works throughout all the links in the different pages? Why is the "s' there?

THanks in advance,

abe

Link to comment
Share on other sites

The Problem - On the main index.php page, the links "log yourself in" and "create an account" seem to go to pages that are not in my web host directory. When I look in it, they are actually there but for some reason won't load. I then checked the actual URL and put the exact one in and would get the appropriate screen. The link that corresponds to the above mentioned contain an "s" in http. It looks like this...

https://yoursitename.com/login.php.

If I take the "s" away, I get to the right site and everything works fine. Can someone please tell me where I can fix this so that it works throughout all the links in the different pages? Why is the "s' there?

THanks in advance,

abe

Look in catalog/includes/configure.php. Make sure you've added the "s" to the designated https server (for admin/includes/configure.php I added the "s" to the http as well as the https server). Enable SSL. That assumes you have SSL.

Link to comment
Share on other sites

That assumes you have SSL.

 

 

And assumes that your host will setup the SSL properly. Some hosts with shared SSL use it in a way the seems incompatible with the oscommerce system in my experience. For example, my host on the ssl I get a blank page on one install and an Internal Server Error 500 on a subsequent install (about to drive me batty too).

Link to comment
Share on other sites

Thanks...I actually changed the address of my https server value in my configure.php file. I had to direct it to a domain given by my host server which uses SSL for that specific address only. Your advice guided me in the right direction and is much appreciated...

Abe

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...