Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Shopping cart help


ikeba

Recommended Posts

Hi,

 

Can someone take a look at my site, if they have the time... http://ikebagifts.com/catalog/

You might need to create an account to see what the problem is (I can delete it afterwards)

 

Here is the problem...

When you create an account or login you are taken to the secured page. While you add items to your cart you are then in non-secure mode again. When you try to checkout, it agains switches to secure mode but your shopping cart comes up empty...

 

Here are snipets of the configure.php in both admin and catalog directories... the admin directory is NOT in the catalog directory, but in the root directory.

 

Thanks in advance.

 

catalog/configure.php...

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://ikebagifts.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://ikebasecure.mygisol.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'ikebagifts.com');
 define('HTTPS_COOKIE_DOMAIN', 'ikebasecure.mygisol.com');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

admin/configure.php...

// define our webserver variables
// FS = Filesystem (physical)
// WS = Webserver (virtual)
 define('HTTP_SERVER', 'https://ikebasecure.mygisol.com'); // eg, http://localhost or - https://localhost should not be NULL for productive servers
 define('HTTP_CATALOG_SERVER', 'http://ikebagifts.com');
 define('HTTPS_CATALOG_SERVER', 'https://ikebasecure.mygisol.com');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
 define('DIR_WS_ADMIN', '/admin/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

Link to comment
Share on other sites

Just wanted to post that, while I don't know what Ikeba's original problem was, I had a problem with a recurring "Your Cart Is Empty!" message even after I added items to the cart. The contents would just dump and I would go around and around in circles.

 

The problem had to do with the STORE_SESSIONS setting in configure.php (both files in admin/includes/ and root/includes).

 

See this post for how I fixed it.

 

Best of luck everybody!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...