Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

An odd transaction


Guest

Recommended Posts

Here, in the UK, we use Protx as our Internet payment gateway.

 

No problems with them ... everything works just fine.

 

However, we were going through our monthly transactions and noticed a transaction to the value of ?90 that we didn't recognise.

 

On checking the customer name on OSC admin, the customer had created a record, but there was no order associated with it..

 

So, someone has managed to create a customer record, go through the checkout and on to Protx and make a successful purchase for ?90 ..... but no order record in OSC.

 

Any ideas ........

Link to comment
Share on other sites

I don't know how Protx works exactly, but I reckon the issue is this.

 

osC only confirms an order after the customer returns from the payment gateway to checkout_success.php

 

So, if the customer pays via Protx, and then for some reason does not return to chechout_success.php (either user error or system error), the money will be in your account, but the order will not be stored.

 

This is a relatively common problem with Paypal if you don't have auto-return enabled - and can still happen from time to time if there is a connection problem.

 

There are contributions out there that recover unpurchased shopping carts, which may help you if it happens in the future.

 

Personally, I just contact the customer and ask why there is ?90 extra in the account - sometimes people just send you money without making an order through the site and "assume" you know what it is for...

- osCommerce is fun! -
Link to comment
Share on other sites

OK, I installed Recover Cart contribution and picked up the order.

 

How do I go about putting an order through OSC without going through the payment process .... so that the customer record and stock file is correct?

Link to comment
Share on other sites

This is a relatively common problem with Paypal if you don't have auto-return enabled - and can still happen from time to time if there is a connection problem.

 

Not having the same problem, but would definitley would like to try to avoid it. How would I go about enableing that "auto-return" and where??

 

Thanks,

 

Josh

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...