Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Intermitant 'page can not be displayed' issue.HELP


Guest

Recommended Posts

ok guys 'n gals. This is a wierd one and has a coupla parts. I just hope someone else has ran into this problem and have found a fix for it.

 

First off: I am runninf PHP4.3 & MySQL 1.4 (have also tried on PHP4.3.4.4 machine)

 

I run into 2 problems installing this software. #1: when I use an IP like 192.168.1.101 OR an hostname like 'catalogserver' for the Database Server name I always run into "Access denied for user: 'MyName@catalogserver' (using password: YES)" I have read through your other topics and haven't found one yet to fix it but many on that topic. BUT when I use 'LOCALHOST' as my Database Server name everything seems to work fine, or so it would seem :blink: which brings me to issue #2: With 'local host' being the database server name everything seems to work fine. I CAN add sections or items and do database stuff fine but I get these intermitant ' The Page cannot be displayed ' errors :mellow: They do not happen on any spacific pages of the catalog. you can sometimes just hit refresh a few times on the same URL and the page will pop up. or just hit backwords click on the link again and it will work fine until the next intermitant cannot display error. :( Please check out http://ItsAffordable.net/catalog/ to view the issue I am speaking of. Remember when page display error happens try refreshing a few times or hitting the back button and repeating and you will see the page pop up like it was always there. :o

 

I have used mysql for many years and never had as many problems until the newer versions of >4.0 - 5.0 . I can only hope someone else has had this issue.

 

I am behind a linksys router but I am guessing this is not an ip port routing issue.

 

I am Using 'Database' for my Session Storage. The reason being when I use 'file' I get the error below:

 

-----------------------------------------------------------------

Warning: session_start() [function.session-start]: open(/tmp\sess_a002d4b54627a568cbb5cb953b91c179, O_RDWR) failed: No such file or directory (2) in C:\LocalNet\Apache2\htdocs\ItsAffordable.net\catalog\includes\functions\sessions.php on line 67

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at C:\LocalNet\Apache2\htdocs\ItsAffordable.net\catalog\includes\functions\sessions.php:67) in C:\LocalNet\Apache2\htdocs\ItsAffordable.net\catalog\includes\functions\sessions.php on line 67

----------------------------------------------------------------

 

 

Any Information would be great and much apreciated! :thumbsup: The more the better. and Thank you to all ahead of time that take the time to respond!

Link to comment
Share on other sites

I forgot to mention that when I use 'File' as my session type i get that error i specified above and I can't add to cart or edit anything. The odd thing is that the intermentant page display error dissapeares!!!!!

SOME ONE HELP PLEASE ... I either need it to work under File with out the error or databaser with page disaplay issue

 

help heklp help help 8P

Link to comment
Share on other sites

in your configure.php files set store_sessions to mysql

 

 

Yes Unfortunantly this was already set to 'mysql' Thanks for the try though anyone else have any thoughts!!! pleeasssee I really want this to work!!! :'( At least mabye someone could let me know what the best versions of apache PHP and mysql that all work together easyly.

 

Thanks

Link to comment
Share on other sites

This is part of your page source code

"</table>

????XT? ?? ? gVQ ?$ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 L $ I 3 0 x $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 (

$ I 3 0 T

$ I 3 0 ?

$ I 3 0 ?

$ I 3 0 ?

$ I 3 0 $ I 3 0 0 $ I 3 0 \ $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 8 $ I 3 0 d $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 @ $ I 3 0 l $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? ?I 3 0 $ I 3 0 H $ I 3 0 t $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ $ I 3 0 P $ I 3 0 | $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 , $ I 3 0 X $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 4 $ I 3 0 ` $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 < $ I 3 0 h $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 D $ I 3 0 p $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 ?L $ I 3 0 x $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 ( $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 0 $ I 3 0 \ $ I 3 0 ? $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 8 $ I 3 0 d $ I 3 0 ? $ I 3 0 $ I 3 0 @ $ I 3 0 ? $ I 3 0 ? $ I 3 0 $ I 3 0 ?VQ ?VQ ?VQ ? ( ?? ?

?, ????? l ????D ??UQ ?D9 ???? > ?e?UQ h?U ???? |

??UQ ??G ????T ??UQ is< ? L x ? ? ? ( T ? ? ? ? 0 \ ? ? ? 8 d ? ? ? ? @ l gVQ h ?VQ ?VQ ?VQ ?VQ ? ~ ? ??_B zVQ ? ( ? , ? ? ????? ? ???? n?M ? ????@ ??M ? ????h ?$ =LDO ? ????? ^?M ? ????? ?$ ~C(M ? ????? B& ?msO ? ???? ٮ 2?P ? ????0 ,

??y?7P ? ????X ? I?7P ? ????? ?$ .^P ? ??????? $/N ? ????? y@ ?WP ? ????? #

??7P ? ???? ?? _='M ? ????H [?9M ? ????p ?$ j?7P ? ????? Q%

??mO ? ????? ݮ ЈqO ? ????? iGrFM ? ???? W ?FM ? ????8 Z 3QVM ? ????` \N ?J\qO ? ?RCRD( zVQ ?? ? ? VP ? WM ????? ??TM ? ????? X 7??FM ? ????? o ??FM ? ???? / ?!KM ? ????( . ٖKM ? ????P ?2 ??nO ? ????x l he?LM ? ????? ?$ ?/N ? ????? 8 oT?nO ? ????? ? ??mO ? ????? C& ?nsO ? ????@ ? ??XM ? ????h <HLM ? ????? - ?LLM ? ????? ٶ ??7P ? ????? %

B?7P ? ???? >) 6V5P ? ????0 1 N?MM ? ????X 2 /?MM ? ????? ????MM ? ????? ?a ,

0P ? ????? ? ߎNM ?? ????? ?a ?0P ? ???? ? ??umsO ? ????H > U=_?P ? ????p ? ??7P ? ????? N ?P ? ????? ? msO ? ????? XN ?A?xP ? ???? ?$ 9!^P ? ????8 } ?PsO ? ????` ?N ?NP ? ????? * ?HP ? ????? ۮ? Ϝ P ? ????? <% .&آ}O ? ???? ? ???mO ? ????( :% 8 ??}O ? ????P ?$ ?CTBsO ? ????x % ) ??}O ? ????? ?? ??}O ? ????? ׮ ?KmO ? ????? x0 1?L?}O ? ????

?% ?_AsO ? ????@

??{O ? ????h

l\

?{O ? ? ?????

ʷvO ? ?????

?% ?@sO ? ?????

=??vO ? ???? "> z?vO ? ????0 # ?uO ? ????X ??uO ? ????? ?? ????uO ? ????? ?C ??uO ? ????? ? ??uO ? ????? $$ F^P ? ???? &$ VE^P ? ????H ?% e?sO ? ? ????p ? ??9?PM ? ????? n9 X C?sO ? ????? > ^?qO ? ????? ?% ?sO ? ????

) W?sO ? ????8

&nQM ? ????`

?#QM ? ?????

?% esO ? ?????

S& ?~sO ? ?????

? (fQM ? ???? lQM ? ????(?!$ qtQM ? ????P .$ ?uQM ? ????x ?% ?rsO ? ????? R& nqsO ? ????? > ?5??qO ? ????? ?q j??/N ? ???? ?% cI?psO ? ????@ ?$ ??QM ? ????h 9 gpsO ? ????? G U?QM ? ????? ?2 ?[qO ? ????? ?$ v^CO ? ? ???? qH ?ZqO ? ????0 a3 pZqO ? ????X Ѷ ?YqO ? ????? ?$ ?XYqO ? ????? ^f ?XqO ? ????? : ?WM ? ????? < ??m1WM ? ???? <table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>"

 

Good job I'm behind a firewall with active virus scanning.

 

Vger

Link to comment
Share on other sites

Good job I'm behind a firewall with active virus scanning.

 

Vger

 

I am not sure what that is or how I can fix it but this is becoming something that it looks like I am not going to get much help on ... close to giving up.

 

Does anyone have a combination of versions that work of php apache and mysql??????

Link to comment
Share on other sites

move your store to a *nix server or other, are you trying to run your store at home or something?

 

Actually yes I am trying to run my store from home. Is this normallya problem?. I have one machine dedicated to webhosting and have so for many years can't remember the last time I turned it off 8P. I have been thinking of going to a unix/linux server base but just never over came the hurdles.

 

I am doing many scans on my system for a virus to see were that machine code is coming from but have found nothing yet.

 

For an XP machine what is the best working combination of version #'s for Apache , PHP & MySQL for OsCommerce?

 

Thank you Mibble and Vqer for your comments in trying to help!

Link to comment
Share on other sites

For an XP machine what is the best working combination of version #'s for Apache , PHP & MySQL for OsCommerce?

 

 

 

Ok guys I think I found out the problem for those of you that have had to endur this thread also for those of you how run into this problem.

 

I have been runing apache 2.somthing .. anyhow I tryed installing all versions of everything from php to mysql .. The issue lies in apache 2.+ I switched back to apacha 1.3+ and everything works fine and dandy all issues reguerding missigng pages and machine code no longer are there thank god!.

 

I am dissapointed i can't Use apache 2.0+ though. what is set wrong in the defualt settings that is causing this to happen if anyone knows and can relate please get back to me. This probably won't happen and this thread will die after this post but ANY INFORMATION AS TO HOW TO GET PHP TO WORK WITH APACHE 2.0+ PROPERLY would be of great help.

 

I am sure this isn't a oscommerce issue!! as I tryed to install phpbbs (another mysql databaser) as a test and got the same issues with apche 2.0+

 

Anyone have simulure results?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...