Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Footer out of control


laputa

Recommended Posts

I've downloaded the latest osc file "oscommerce-2.2ms2.zip" several times and install many times but same problem.

 

My configuration:

OS: Mandrake Linux 9

Apache: 1.3.26

php: 4.2.3

mysql: 3.23.52

 

The position of the footer sometimes appear on bottom of the left column.

 

My web with osc is located at:

http://test1.servehttp.com:8000/catalog/

 

1. First page: the footer position is correct.

2. Click the "Hardware" under "Categories" -> footer's position is correct.

3. Click sub-categories under "Hardware" -> footer escapes to right column sometimes

4. Click the product within the "What's New?" box -> footer escapes to right column sometimes.

 

It is very confusing what happened. The whole osc is newly installed without any amendment.

 

When the problem occures, I've tried checking the index.php line by line and found:

 

index.php

 

345: <td width="100%" height="14" class="infoBoxHeading">Currencies</td>

346: <td height="14" class="infoBoxHeading" nowrap><img src="images/pixel_trans.gif" border="0" alt="" width="11" height="14"></td>

347: </tr>

348: </table>

349: <table border="0" width="100%" cellspacing="0" cellpadding="1" class="infoBox">

350: <tr>

351: <td><table border="0" width="100%" cellspacing="0" cellpadding="3" class="infoBoxContents">

352: <tr>

353: <td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="1"></td>

354: </tr>

355: <tr>

356: <td align="center" class="boxText"><form name="currencies" action="http://seannatest1.servehttp.com:8000/catalog/index.php" method="get"><input type="hidden" name="osCsid" value="c27b8dbe6ff84fccb64fa1d39417e762" /><select name="currency" onChange="this.form.submit();" style="width: 100%"><option value="USD" SELECTED>US Dollar</option><option value="EUR">Euro</option></select><input type="hidden" name="cPath" value="1_4"><input type="hidden" name="sort" value="2a"><input type="hidden" name="osCsid" value="c27b8dbe6ff84fccb64fa1d39417e762"></form></td>

357: </tr>

358: <tr>

359: <td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="1"></td>

360: </tr>

361:</table>

362: </td>

363: </tr>

364:</ </td> <----------------------- problem here

365: </tr>

366: <!-- currencies_eof //-->

367: <!-- right_navigation_eof //-->

 

the problem is found at line 364 where incomplete html code "</" is found. This code should be generated in "/var/www/html/test/catalog/includes/column_right.php" and it includes the file "/var/www/html/test/catalog/includes/boxes/currencies.php", all seems working properly but just the resulting page with the incomplete html code ??????

 

Please give me any advice or suggestion as possible. It has frustrated me for a week .... I've tried reading the codes again and again. My head is painful now.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...