Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

all kinds of problems


leemarch

Recommended Posts

I've moved my OsCommerce store to a new server and it went completely haywire. My modules all dissapeared from my admin section. I'm being told that directories for images, backups, and file manager don't exist.

 

here are my configure.php files......any thoughts

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.carrycell.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.carrycell.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'carrycell.com');
 define('HTTPS_COOKIE_DOMAIN', 'carrycell.com');
 define('HTTP_COOKIE_PATH', '/osCommerce/catalog/');
 define('HTTPS_COOKIE_PATH', '/osCommerce/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/osCommerce/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/osCommerce/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', 'home/content/l/o/i/loisfox/osCommerce/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'mysql3.secureserver.net'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'carrycellcart');
 define('DB_SERVER_PASSWORD', 'bubba');
 define('DB_DATABASE', 'carrycellcart');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.carrycell.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.carrycell.com');
 define('HTTPS_CATALOG_SERVER', 'https://www.carrycell.com');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/osCommerce/catalog/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/osCommerce/catalog/'); // absolute path required
 define('DIR_FS_CATALOG', 'home/content/l/o/i/loisfox/html/osCommerce/catalog/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backup/');

// define our database connection
 define('DB_SERVER', 'mysql3.secureserver.net'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'carrycellcart');
 define('DB_SERVER_PASSWORD', 'bubba');
 define('DB_DATABASE', 'carrycellcart');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

what seems to be the problem?????

Link to comment
Share on other sites

uh, might be a good idea to nix out your db username and password.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Also, do you images reside at http://www.carrycell.com/images?

 

Or do you have them installed in a subdirectory, like http://www.carrycell.com/shop/images?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Is this your website,

http://www.carrycell.com/osCommerce/catalog/

 

Looks like all the pictures are there to me.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Is this your website,

http://www.carrycell.com/osCommerce/catalog/

 

Looks like all the pictures are there to me.

 

yes, that's it. I figure out the image thing, but I'm still having huge issues.

 

all of my modules dissapeared from my admin section.( they are still physically in place on my server and I believe the paths are correct)

 

I get this in my backup page:

Error: Backup directory does not exist. Please set this in configure.php.

the directory indicated in the path shown on the page does physically exist on my server and is chmod 777

 

Warning: dir(/home/content/l/o/i/loisfox/html/osCommerce/catalog/): failed to open dir: No such file or directory in /home/content/l/o/i/loiscindy/html/osCommerce/catalog/admin/file_manager.php on line 178

 

Fatal error: Call to a member function on a non-object in /home/content/l/o/i/loiscindy/html/osCommerce/catalog/admin/file_manager.php on line 179

 

This path doesn't exist anywhere in my configure.php files......I'm totatlly lost and frustrated!!!!!!!!!!!!!!ARRRRRRRRRRRRGH

This is what I see on my file manager :

Warning: dir(/home/content/l/o/i/loisfox/html/osCommerce/catalog/): failed to open dir: No such file or directory in /home/content/l/o/i/loiscindy/html/osCommerce/catalog/admin/file_manager.php on line 178

 

Fatal error: Call to a member function on a non-object in /home/content/l/o/i/loiscindy/html/osCommerce/catalog/admin/file_manager.php on line 179

Link to comment
Share on other sites

OK, deep breath. Everything will be ok.

 

Trust me, this is the LEAST frustrating thing you're going to encounter learning how to be a web programmer.

 

Anyways, all of your problems are most likely due to your configuration paths that you have defined.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

OK, deep breath. Everything will be ok.

 

Trust me, this is the LEAST frustrating thing you're going to encounter learning how to be a web programmer.

 

Anyways, all of your problems are most likely due to your configuration paths that you have defined.

is there anything in particular that strikes you as possibly wrong in my configure.php files?

 

I've looked over them probably a thousand times....and I must be missing something.

Link to comment
Share on other sites

define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/

 

if you have the store up, go to the admin section tools and server info

search for document_root

you will find it is most likely:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox

Link to comment
Share on other sites

Ummn, I see all of your admin modules.

 

http://www.carrycell.com/osCommerce/catalog/admin/orders.php

 

(you should probably password protect that thing, lol)

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Oh, I see, you mean you payment and shipping modules arent there.

 

Well, is there anything in your

http://www.carrycell.com/osCommerce/catalo...modules/payment

and

http://www.carrycell.com/osCommerce/catalo...odules/shipping directories?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Oh, I see, you mean you payment and shipping modules arent there.

 

Well, is there anything in your

http://www.carrycell.com/osCommerce/catalo...modules/payment

and

http://www.carrycell.com/osCommerce/catalo...odules/shipping directories?

nope.....I had my store completely up and running on another server. When we moved servers it just went completely nuts.

Link to comment
Share on other sites

define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/

 

if you have the store up, go to the admin section tools and server info

search for document_root

you will find it is most likely:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox

thanks.....I tried that....still no solutions :(

Link to comment
Share on other sites

Admin/configure.php

BACK UP FIRST ;) I am not always right.

<?php
/*
osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2003 osCommerce

Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://www.carrycell.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTP_CATALOG_SERVER', 'http://www.carrycell.com');
define('HTTPS_CATALOG_SERVER', 'https://www.carrycell.com');
define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox/html/'); // where the pages are located on the server
define('DIR_WS_ADMIN', '/admin/'); // absolute path required
define('DIR_FS_ADMIN', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/admin/'); // absolute pate required
define('DIR_WS_CATALOG', '/osCommerce/catalog/'); // absolute path required
define('DIR_FS_CATALOG', 'home/content/l/o/i/loisfox/html/osCommerce/catalog/'); // absolute path required
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backup/');

Link to comment
Share on other sites

Admin/configure.php

BACK UP FIRST  ;) I am not always right.

<?php
/*
osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2003 osCommerce

Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://www.carrycell.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTP_CATALOG_SERVER', 'http://www.carrycell.com');
define('HTTPS_CATALOG_SERVER', 'https://www.carrycell.com');
define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
define('DIR_FS_DOCUMENT_ROOT', '/home/content/l/o/i/loisfox/html/'); // where the pages are located on the server
define('DIR_WS_ADMIN', '/admin/'); // absolute path required
define('DIR_FS_ADMIN', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/admin/'); // absolute pate required
define('DIR_WS_CATALOG', '/osCommerce/catalog/'); // absolute path required
define('DIR_FS_CATALOG', 'home/content/l/o/i/loisfox/html/osCommerce/catalog/'); // absolute path required
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backup/');

 

I tried that, no luck...thanks anyway though :D

Link to comment
Share on other sites

In your admin/configure.php

define('DIR_FS_CATALOG', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/'); // absolute path required

 

All that is needed to get added is a / in

 

http://www.carrycell.comoscommerce/Catalog/admin/modules.php?

 

so it is

 

http://www.carrycell.com/oscommerce/Catalo...min/modules.php?

 

this is what I currently have......all problems still persist

 define('DIR_FS_CATALOG', '/home/content/l/o/i/loisfox/html/osCommerce/catalog/');

Link to comment
Share on other sites

It looks all fine to me now.

 

 

I just don't get it I'm still having problems in my admin with file manager, all my modules are gone, I'm getting an error on define languages. In my store my checkout page turns up a 404 as well as create account and my account even though all these files are physically there. ????

Link to comment
Share on other sites

It still looks all fine to me.  I got to your create account page without a problem.

 

I got everything else fixed.....it was some stupid path bs.

 

I don't understand why the create account thing isn't working on my machine....i'll try one of my other machines and see what happens.

 

 

Thanks you so much for all your help!!!!

Link to comment
Share on other sites

for the create account try refresh, it was there for me. Don't forget about the other PM things.

 

Glad you are back up and running.

 

Peter

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...