Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Ok, where did it all go?


Guest

Recommended Posts

Post a link.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

OK, you tried to edit your footer.php, either directly or in the language directory, and you have made an error in doing so.

 

Post what you changed, and we'll help you fix it.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

that's the funny thing.

 

The only thing that I edited tonight was a livehelp.php function that I added and I did a search on my index.php file as well...

 

I don't remember actually changing anything. What should I be looking for on my index.php page?

Link to comment
Share on other sites

If it's a problem in your index.php, then it's here....

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

 

However, I still think it's in either

/catalog/includes/footer.php

 

or

 

/catalog/includes/languages/english/footer.php

 

Probably the latter.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Ok, go figure, I no longer have a /catalog/includes/languages/english/footer.php

 

How can that just disappear without me even deleting it?

Link to comment
Share on other sites

Dunno, but you'll need that.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Apparently I don't need that.

 

I just loaded a fresh store from my host & I don't have that in my "dummy" store either.

 

got another suggestion?

Link to comment
Share on other sites

opps, duh, they put the language define in

/catalog/includes/languages/english.php

 

Your error is probably at the very bottom.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Hmmn, that looks ok to me.

 

Did you also make changes to the /catalog/includes/footer.php file? If so, post them.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Nope, like I said

 

The only thing that I changed is this file

 

<?php
/*
 $Id: information.php,v 1.6 2003/02/10 22:31:00 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/
?>
<!-- information //-->
         <tr>
           <td>
<?php

 $info_box_contents = array();
 $info_box_contents[] = array('text' => BOX_HEADING_LIVEHELP);

 new infoBoxHeading($info_box_contents, false, false);

 $info_box_contents = array();
 $info_box_contents[] = array('align' => 'center', 'text' => '<script language="javascript" src="https://5alarmgifts.sslpowered.com/store/nfoscomm/catalog/livehelp/livehelp_js.php?relative=Y&department=1&username=<?php echo $_SESSION['username'] ?> "></script>;

 new infoBox($info_box_contents);
?>
           </td>
         </tr>
<!-- information_eof //-->
</td>
</tr>
<TR>
<TD>
<IMG SRC="images/info_box_right_shadow.gif" WIDTH=100% HEIGHT=13></TD>
</TR>

 

the only thing that I had changed was a minor thing to recognize my clients.

 

I have no idea what could have changed. I haven't gone into my footer.php file in forever.... I'll post it.....

 

 

<?php
/*
 $Id: footer.php,v 1.26 2003/02/10 22:30:54 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

 require(DIR_WS_INCLUDES . 'counter.php');
?>
<table border="0" width="100%" cellspacing="0" cellpadding="1">
 <tr class="footer">
   <td class="footer">  <?php echo strftime(DATE_FORMAT_LONG); ?>  </td>
   <td align="right" class="footer">  <?php echo $counter_now . ' ' . FOOTER_TEXT_REQUESTS_SINCE . ' ' . $counter_startdate_formatted; ?>  </td>
 </tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr>
   <td align="center" class="smallText">
<?php
/*
 The following copyright announcement can only be
 appropriately modified or removed if the layout of
 the site theme has been modified to distinguish
 itself from the default osCommerce-copyrighted
 theme.

 For more information please read the following
 Frequently Asked Questions entry on the osCommerce
 support site:

 http://www.oscommerce.com/community.php/faq,26/q,50

 Please leave this comment intact together with the
 following copyright announcement.
*/

 echo FOOTER_TEXT_BODY
?>
   </td>
 </tr>
</table>
<?php
 if ($banner = tep_banner_exists('dynamic', '468x50')) {
?>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr>
   <td align="center"><?php echo tep_display_banner('static', $banner); ?></td>
 </tr>
</table>
<?php
 }
?>

<?php
///////////////////
// [0001] WebMakers.com Added: Center Shop
// This goes at the very end of the footer after all the tables
///////////////////

 if ( CENTER_SHOP_ON == 'on' ) {
  
///////////////////
// [0001] close table used to center
///////////////////
?>
     </td></tr>
   </table>
<?php
   if ( CENTER_SHOP_BACKGROUND_ON == 'on' ) {
    
///////////////////
// [0001] Add color to bottom of screen for large displays - needed especially on notebooks that run at 1600x1200
// close table used for outer bgcolor around the shop
///////////////////
?>
     </td></tr>
     <tr><td height="150"> </td></tr>
   </table>
<?php
   }
 }
///////////////////
// [0001] EOF: WebMakers.com Added: Center Shop
///////////////////
///////////////////
?>

 

 

Does any of this make any sense?

Link to comment
Share on other sites

This doesn't look right....

 

$info_box_contents[] = array('align' => 'center', 'text' => '<script language="javascript" src="https://5alarmgifts.sslpowered.com/store/nfoscomm/catalog/livehelp/livehelp_js.php?relative=Y&department=1&username=<?php echo $_SESSION['username'] ?> "></script>;

 

You have php embeeded in Java, embedded in html, embedded in php.

 

And it's not the right syntax. You didn't close your open single quote.

 

Is that something you changed?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

This might be a little closer....

 

 

$info_box_contents[] = array('align' => 'center', 'text' => '<script language="javascript" src="https://5alarmgifts.sslpowered.com/store/nfoscomm/catalog/livehelp/livehelp_js.php?relative=Y&department=1&username=' . $_SESSION['username'] . '"></script>';

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

yes that is the file that I changed.

 

What does it need to look like for it to work? As I'm sure that you can tell, I'm kinda php stupid! LOL!

Link to comment
Share on other sites

Just put it back the way it was.

 

Or, take the variable off, so you can see for sure if this is the problem.

 

 

$info_box_contents[] = array('align' => 'center', 'text' => '<script language="javascript" src="https://5alarmgifts.sslpowered.com/store/nfoscomm/catalog/livehelp/livehelp_js.php?relative=Y&department=1"></script>';

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Restore it with the original.

 

If you no longer have it, download the latest OSC, and use the file from that. They should still be the same.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Restore it with the original.

 

If you no longer have it, download the latest OSC, and use the file from that. They should still be the same.

 

 

 

Are you talking about the livehelp.php file? That was just an add in. I'll check to see if I still have it.

 

If not, what other options would there be? Do I have to remove a "call" from another file?

Link to comment
Share on other sites

Ok, wait.

 

Live help? Is this a new box that is supposed to appear in your right hand column? Did you make a change to the /catalog/includes/column_right.php ?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...