Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems configuring SSL


funkyshop

Recommended Posts

Hello!

 

I have already searched the forum and found tons of information concerning my problem. However none is solving it.

 

I have an SSL-cerificate for a site I currently work at and it seems to work fine.

As a test I put a test-site into it:

https://www.der-pavillon-shop.de/webshop/catalog/test.htm

 

And there is the lock (stating one is on a secure site) in the bottom of the browser just as it should be. However the webshop itself doesn't show the lock:

https://www.der-pavillon-shop.de/webshop/catalog/

 

The configuration of the includes\configure.php:

define('HTTP_SERVER', 'http://www.der-pavillon-shop.de');

  define('HTTPS_SERVER', 'https://www.der-pavillon-shop.de');

  define('ENABLE_SSL', true); // secure webserver for checkout procedure?

  define('HTTP_COOKIE_DOMAIN', 'www.der-pavillon-shop.de');

  define('HTTPS_COOKIE_DOMAIN', 'www.der-pavillon-shop.de');

  define('HTTP_COOKIE_PATH', '/webshop/catalog/');

  define('HTTPS_COOKIE_PATH', '/webshop/catalog/');

  define('DIR_WS_HTTP_CATALOG', '/webshop/catalog/');

  define('DIR_WS_HTTPS_CATALOG', '/webshop/catalog/');

  define('DIR_WS_IMAGES', 'images/');

 

So does any of you guys have an idea why the lock isn't shown properly for the shop itself? I already tried

define('HTTPS_SERVER', 'https://der-pavillon-shop.de');

instead but it doesn't work out either.

 

Thanks

 

Samuel

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...