Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Step 7 installation problem


eraniopub

Recommended Posts

dear members

i installed php 4.3.9 and Mysql as a system service. i have win xp pro with iis.

i create in mysql empty database scheme called 'oscommerce' and assign a user with password and all the privilages.

i put the oscommerce files in the public directory and run the installation proccess,

in level 7 it display me this error:

 

New Installation
osCommerce Configuration

Warning: fopen(c:/inetpub/wwwroot/oscommerce/catalog/includes/configure.php): failed to open stream: Permission denied in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 209

Warning: fputs(): supplied argument is not a valid stream resource in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 210

Warning: fclose(): supplied argument is not a valid stream resource in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 211

Warning: fopen(c:/inetpub/wwwroot/oscommerce/catalog/admin/includes/configure.php): failed to open stream: Permission denied in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 259

Warning: fputs(): supplied argument is not a valid stream resource in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 260

Warning: fclose(): supplied argument is not a valid stream resource in c:\inetpub\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 261
The configuration was successful!

 

i looked back in the forum for few hours and didn't found any solution. i found that maybe i need to edit manualy the configure.php files in the catalog directory, so i changed these files to look like

// define our database connection
 define('DB_SERVER', 'localhost');   define('DB_SERVER_USERNAME', 'myname');
 define('DB_SERVER_PASSWORD', 'mypass');
 define('DB_DATABASE', 'oscommerce');
 define('USE_PCONNECT', 'false'); 
 define('STORE_SESSIONS', 'mysql');

 

it didn't help. please let me know if you know any solution or clue about it.

thankz,

eranio pub.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...