Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Site Security


Vince Herchmer

Recommended Posts

Not sure what it is called, but the lock that appears at the bottom of my IE browser to indicate a secure page does not appear. When logged-in on my order page, a check of page properties will show access through my secure server but there is no browser indication.

 

Any help would be appreciated.

 

Thanks

Vince Herchmer

Alberta, Canada

Link to comment
Share on other sites

Its called SSL certificate, issued by companies that say this site is reliable and if anything happen to make you loose because of insecure site we will reimburse you.

 

You should ask your hosting provider for the certificate and how to install it

 

Peace,

--------------------------------

Link to comment
Share on other sites

You're probably using frames - that will cause this problem. The frame parent is not secure but the subframe is. You won't get the lock icon unless the whole page is secure.

Link to comment
Share on other sites

You're probably using frames - that will cause this problem.  The frame parent is not secure but the subframe is.  You won't get the lock icon unless the whole page is secure.

 

Steve,

 

Thanks for your answer. However, I'm using the os-commerce program in it's basic unaltered state and don't know if it is using frames or not. I have no programming knowledge so just happy to see it working.

 

The security icon did at one time always appear on the check-out page but suddenly it is gone. The only change made recently was I had my images coming through secure server (shared ssl) and changed to my reg domain server to try and save some loading time.

 

Any other suggestions??

 

THANKS AGAIN

Vince Herchmer

Alberta, Canada

Link to comment
Share on other sites

When you link to images not on a secure (https) server, in IE anyways, it brings up a window indicating there are secure and not secure items, and do you want to view only the secure or both.

 

This little window also asks if you want to see it (the little window) again, allowing you to check or not check whether you do or not.

 

If you check not to see the window again, you won't.

 

At this point you will be seeing both secure and not secure items, and the lock in the status bar will not show.

 

In order for the lock to show you will have to return your images to a secure server environment.

 

I'm only 97% sure of this.

 

Carlos

Link to comment
Share on other sites

Give us a URL to look at so we can see the problem for ourselves.

 

Thanks for taking another look at this for me.

 

The site is located at http://HorizonKites.com

 

I tried Carlos' suggestion and changed access to images and icons through my secure server but still the same results.

 

While logged-in I checked the properties of all the page components and found them ALL to be secure, but still no status bar lock.

 

This affected the page loading speed so much (shared SSL) that I moved the images back to the non-secure server.

 

My main concern is that this might be a deterant for online purchases if the shopper isn't aware that the security can be verified by a right mouse click.

Vince Herchmer

Alberta, Canada

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...