Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Needing help on Currency keeps changing!


Guest

Recommended Posts

:'(

help guys I'm still new to PHP & mySQL

 

I have the main currency set to default on AUD australian currency but it keeps defaulting to USD whenever you go to another page, any page and checks out on USD.

 

I have tried to keep AUD as the only currency but then everything shows $0! So then I put USD back in but same problem occurs again.

I have tried renaming them and swapping it but still same

 

nothing was altered or changed in any files and all was working fine till today.

I am absolutely stuck on this.

 

I saw some people had the same problems but no one replied to them.

 

please help

 

thanks in advance

 

Allen

Link to comment
Share on other sites

Did you created a new default currency?

In the edit did you put 1.0000000 as the value and then click on update currencies button ?

and in the catalog/includes/languages/english.php around line 36

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used w$

 

define('LANGUAGE_CURRENCY', 'USD');

Change it to whatever you need

 

HTH

The_Bear

Link to comment
Share on other sites

:'(

help guys I'm still new to PHP & mySQL

 

I have the main currency set to default on AUD australian currency but it keeps defaulting to USD whenever you go to another page, any page and checks out on USD.

 

I have tried to keep AUD as the only currency but then everything shows $0! So then I put USD back in but same problem occurs again.

I have tried renaming them and swapping it but still same

 

nothing was altered or changed in any files and all was working fine till today.

I am absolutely stuck on this.

 

I saw some people had the same problems but no one replied to them.

 

please help

 

thanks in advance

 

Allen

Hi I think you problem might be that after you set aud as default you also need to set aud values to 1:10000 and say the usd price to current conversions rate because from default USD is set to 1:10000 hope this might help. :blink:

( WARNING )

I think I know what Im talking about.

BACK UP BACK UP BACK UP BACK UP

Link to comment
Share on other sites

Thanks guys you are quick to reply and help

I finally found it after a quick chat to my PHP buddy

 

under includes/languages/english.php

 

line 40 has this

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used when changing language)

define('LANGUAGE_CURRENCY', 'AUD');

 

somehow it was changed to USD instead of AUD. I have no idea how it happened but it did and had to be manually altered then FTPed back up because it wouldn't change thru the admin panel.

 

works now after entering ALL the currencies back in again. what a pain something small like that

Link to comment
Share on other sites

Did you created a new default currency?

In the edit did you put 1.0000000 as the value and then click on update currencies button ?

and in the catalog/includes/languages/english.php around line 36

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used w$

 

define('LANGUAGE_CURRENCY', 'USD');

Change it to whatever you need

 

HTH

The_Bear

 

 

Thanks The_Bear you were right on the money. what a legend!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...