Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Now I have this problem


MarsBar

Recommended Posts

Warning: I am able to write to the configuration file: /var/www/html/oscommerce/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

How do I change the user permissions?

Thanks,

Mark.

Link to comment
Share on other sites

chmod 644 (-rw-r--r--) should be ok for your "oscommerce/includes/configure.php".

 

On some servers you must set whole /includes/ directory to chmod 644.

 

Have you checked does your settings in configure.php and filenames.php in /includes/ directory pointing to correct locations?

Link to comment
Share on other sites

I tried all what people have suggested.

 

When I changed the whole directory chmod to 644 I get this message on a blank screen:

Warning: main(includes/application_top.php): failed to open stream: Permission denied in /var/www/html/oscommerce/index.php on line 13

Fatal error: main(): Failed opening required 'includes/application_top.php' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/oscommerce/index.php on line 13

 

Tried setting to 600 & 744 and still get original error warning msg!

Peeing me off now! :rolleyes:

Link to comment
Share on other sites

Ok here's how to solve this problem if anyone else gets/has it!

 

Set chmod of directory oscommerce/includes to 755. This allows you to edit the files inside so you can now change the chmod of configure.php to 500.

 

Worked fine for me. \o/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...