Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help Please on create_account.php


siwu

Recommended Posts

Hi All,

 

Any boody can help me with is error with create_account.php. When I click to create an account, IE complaints about an script error occure. The accutal error message is Line: 100

Char: 52

Error: Invalid Character

Code: 0

 

I looked at create_account.php Line 100, it looks ok to me.

 

Here is the Line 100 code

 

$messageStack->add('create_account', ENTRY_EMAIL_ADDRESS_ERROR_EXISTS);

 

Any idea please, it drive me nut !! :angry:

 

Your kindly reply is most appreciated.

 

 

Regard

 

siwu :)

Link to comment
Share on other sites

if IE is poping up with a JScript error it is referrring to line 100 of the HTML source, not the php Source

 

IE never sees the php source code. there is nothing wrong with the php

 

right click --> veiw source

 

paste lines 90 through 100 here

Link to comment
Share on other sites

Yep, it's javascript error. Look like there is something wrong in variables or maybe ';' sign is missing from the end of the line. If you post here that HTML-code of the lines 90-105 I can tell you more.

 

Inside js variables you must use \ before @,' and "

 

For example:

 

var error_message = "Error: you must fill in "address" field\n";

 

or

 

var error_message = 'Error: you must fill in 'address' field\n';

 

will produce js error, but

 

var error_message = "Error: you must fill in \"address\" field\n";

 

or

 

var error_message = 'Error: you must fill in \'address\' field\n';

 

 

or

 

var error_message = 'Error: you must fill in "address" field\n';

 

 

will work ok. Note that you can use " inside ' pairs or ' inside " pairs without \.

Link to comment
Share on other sites

  • 5 weeks later...

I had the same problem. You are probably using another language than the standard ones.

 

Remove all the font tags in your new language.php file (the one in the languages directory). I did that with my dutch.php file and the problem was solved.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...