Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

$language not being asigned


mrbentley

Recommended Posts

Greetings

 

I believe this is a configuration problem..

 

Upon migrating my project to my web host's server, I am getting the following problem when trying to run OSCommerce:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\wezimbabwe.org\httpdocs\catalog\includes\application_top.php on line 299

 

It appears that the variable $language is not being populated, and so the none existent file .php is trying to be opened.

 

Any ideas PLEASE :( :blink:

Link to comment
Share on other sites

Thanks for the swift reply!!

 

Unfortunately I cannot use admin, as I get the same error:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\wezimbabwe.org\httpdocs\catalog\admin\includes\application_top.php on line 126

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\wezimbabwe.org\httpdocs\catalog\admin\includes\application_top.php on line 126

 

Dya know how I can do this manually?

 

Cheers ;)

Link to comment
Share on other sites

In case anyone else is interested, I have now resolved this problem. It appeared to be related to the fact that my site was hosted on NT with IIS. I got my hosting company to switch it to Linux/Apache. It then worked fine. :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...