Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

very weird ... search on header.php


minuteago

Recommended Posts

In the catalog/includes/header.php, I added these codes for adding a small search box which is orignally located at the left side menu.

 

<font size=1><b>Search:</b></font size=1> <?php echo tep_draw_form('advanced_search', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get'). tep_draw_hidden_field('search_in_description','1') . tep_draw_input_field('keywords','','size="10" maxlength="30" style="width: ' . (BOX_WIDTH-30) . 'px"')?>
   <input type="image" src="includes/languages/english/images/buttons/button_search.gif" border="0" alt="Quick Find" title=" Quick Find "></form>

 

The problem by adding these codes is I can't use dropdown manufactuerer box right below the categoreis box. If I choose FOX, the advanced search page comes up and shows me an error message like

At least one of the fields in the search form must be entered.

 

If I type any single word in a search criteria box, then it will find any product starting with the word I just type within the FOX category..

 

Why does this happend? the coding is not correct?

If I re-install the orignal header.php file, then it works the way it does..

 

 

Can anyone tell me what is wrong with this?

 

 

 

thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...