Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

GETTING INTERNAL ERROR MESSAGE


thekar2

Recommended Posts

I was addning new items to my store and everything was going well. I check my site periodically to be sure everything is loading correctly and I received this...

 

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

--------------------------------------------------------------------------------

 

Apache/1.3.29 Server at www.thekarmicconnection.com Port 80"

 

I switched screenames and logged in again but it did not help. I deleted my temporary internet files that would delete and that did not help . I even restored a backup version from 2 hours earlier but that did not help. I hope someone can help me. THIS SUCKS!!!!

 

Please try www.thekarmicconnection.com and let me know if you receive the same error AND if you can help me.

 

THANKS.

Link to comment
Share on other sites

Oddly enough, I got this same error this morning. I'd been monkeying with the site, though: I'd edited the .htaccess file in the catalog/ directory.

 

When I deleted the .htaccess file, the site came back up. I suggest you try that.

 

You shouldn't get rid of the .htaccess file altogether, though. If deleting the file brings the site back up, try making a new .htaccess file with the default data in it, & try the site again.

 

The content of the catalog/.htaccess file should be:

 

# $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
   SetEnvIf User-Agent ".*MSIE.*" \
            nokeepalive ssl-unclean-shutdown \
            downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# Fix certain PHP values

#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>

 

I hope this helps - it's a funny coincidence that we both had this same nasty error on the same morning.

Link to comment
Share on other sites

That is odd that it happened to you too. I tried your instructions but it did not work for me.

 

This is what my error log says when I log in to my hosting company:

 

[Mon Jul 5 10:59:02 2004] [error] [client 205.188.116.143] File does not exist: /home/thekar2/public_html/500.shtml

[Mon Jul 5 10:59:02 2004] [error] [client 205.188.116.143] Premature end of script headers: /home/thekar2/public_html/index.php

 

Can anyone tell me what that means and how to fix it?

Link to comment
Share on other sites

I reached out to my support at Lunarpages and they fixed it right after I sent them the issue! They ROCK! It had to do with security upgrades and I needed to change code in my .htaccess file. Way over my head!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...