Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

managingdirector

Members
  • Content count

    4
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. managingdirector

    Cannot Install V4 Database

    Solved: CentOS Linux 7.9.2009 does not support MySQL version 5.6.31, 5.7, 8.0 or MariaDB 10+ Suggest that the error message "Error. Can't update database." link to minimum requirements set forth in https://wiki.oscommerce.com/index.php?title=Installing_osCommerce_v.4.0 .
  2. managingdirector

    Cannot Install V4 Database

    I am able to install osCommerce Online Merchant v2.3.4.1 on the same server as a test without any issues. Since some of the tables load, the problem appears to lie in the installation completing the job. Here are more details: Host: localhost:3306 (MariaDB) CPU: Intel(R) Xeon(R) CPU E5-2683 v3 @ 2.00GHz (2 core(s)) Control Panel: Plesk Obsidian v18.0.45_build1800220722.09 os_CentOS 7 OS: CentOS Linux 7.9.2009 (Core) PHP: 7.4.30 Database Server: localhost:3306 Database Name: OSC4DATABASE Tables loaded: access_control_list [InnoDB utf8_general_ci] 48.0 KiB access_levels [InnoDB utf8_general_ci] 16.0 KiB address_book [InnoDB utf8_general_ci] 32.0 KiB address_format [InnoDB utf8_general_ci] 16.0 KiB admin [InnoDB utf8_general_ci] 80.0 KiB - admin_box [InnoDB utf8_general_ci] 16.0 KiB
  3. managingdirector

    Cannot Install V4 Database

    When installing "Installation v.4.02 build 49998", "Step 3", "Database Access", the installation script throws an error: "Error. Can't update database." The database initialization stopped after the 5th table: "admin_boxes". Is there a fix for this?
  4. USPS updated their Web Tools APIs on July 28th, 2022. See: https://www.usps.com/business/web-tools-apis/2022-web-tools-release-notes.pdf Our osCommerce Online Merchant v2.3.4.1 shopping cart no longer includes USPS as a shipping option. The module name is usps.php 46KB dated 19/11/14 The header from our USPS shipping module is: "USPS Rate V4 Intl Rate V2 $Mod: Changed from Parcel Post to Standard Post 20130129 Kymation $ $Mod: USPS API changes 20130729 Kymation v 1.3 $ $Mod: USPS API changes 20140310 a.forever $ $Mod: USPS API changes 20140802 a.forever $ $Mod: USPS API changes 20140823 Kymation v 1.4 $ $Mod: USPS API changes 20140907 Kymation & a.forever v 1.5 $ Copyright (c) 2012 osCbyJetta Released under the GNU General Public License" Is there a fix for this broken software?
×