Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Pelvis

Members
  • Content count

    67
  • Joined

  • Last visited

Everything posted by Pelvis

  1. I have a multilingual Store with 3 Languages (English German and Greek) if a customer change the language of the store then it should displayed another image depends on the language. See the code that I have manage but the problem is that all three images are displayed but I want only the image from the Language that is selected on shops dropdown to be displayed not all 3 only one banner. <?php /* BOF multilanguage images */ if ($language='en') {echo '<img style="margin-top:4px;" src="images/english-banner.png" height="40">'; } if ($language='de') {echo '<img style="margin-top:4px;" src="images/german-banner.png" height="40">'; } if ($language='gr') {echo '<img style="margin-top:4px;" src="images/greek-banner.png" height="40">'; } // EOF multilanguage images ?>
  2. Pelvis

    need your very litle time :-)

    What's your opinion about new OSC 4? based on a MVC frameworks Yii , more complicated its a system on another system :-)
  3. Pelvis

    need your very litle time :-)

    I have find it! ...This is what i want, thanks for your nice time here Jack 🙂
  4. Pelvis

    need your very litle time :-)

    Hello old man? You are one of the dinosaurs here on OSC forum ...you are not tired yet? Happy to see people that have passion on OSC 🙂 This doesn't work Jack if I do apply the changes nothing was displayed like the attached picture. <?php /* BOF multilanguage images */ if ($language=='en') {echo '<img style="margin-top:4px;" src="images/english-banner.png" height="40">'; } if ($language=='de') {echo '<img style="margin-top:4px;" src="images/german-banner.png" height="40">'; } if ($language=='gr') {echo '<img style="margin-top:4px;" src="images/greek-banner.png" height="40">'; } // EOF multilanguage images ?>
  5. 2 simple questions (of course i have searched and couldn find an answer). 1. If you have instaled b2b or the simplefied version of b2b and iosc-mobile, is B2B working in iosc mobile when somebody visit the site from a mobile phone I mean the prices did they apear as in the desktop version or must i install the b2b as a separet version for iosc-mobile again? Or a link where I can read something about that. 2. General question does this iosc-mobile contrib affect only to the design e.g. css or do you have to install all the contributions that the desktop shop have for to the iosc-mobile version again. Or a link where I can read about a small explantetion for how this contrib works.
  6. @@dominic Did the standard Tetimonials from Burt have this Problem? do you know?
  7. I have try everything and can not fix. The question is why the html_text are displayed with no problems in admin (at the right side of the page) and not on the Frontpage Box. I saw the code but I can;t transfer it at th FrontPage. Thanks for trying.
  8. Hallo Dominic! I found a "bug" in this Contib which I trying to fix for more than 5 Days but it is impossible I can't! (I am not a programmer) I use OSC about 11 Years and I learned a lot of things fixing this and that by my self. and with the help of the people of the OSC community. in my Language witch is Greek, I use utf8 encoding and everything is ok in the shop. The main Text in the Fontend displays a "utf8 Replacement character" it has something with the rendering of php or something like that. In the Database looks everything fine the characters are displayed o.k. but not in the Frondend. Put the follow text in a second Language in your database in the Table "testimonials_html_text" the character encoding of the text Tables must be set to "utf8_unicode_ci" and look in the Frontend how it is displayed. ================== testimonials_html_title: Καλά Παιδιά ================== testimonials_html_text: Άψογη εξυπηρέτηση, ασυναγώνιστη ποιότητα και πάνω από όλα καλές τιμές. ================== testimonials_name: Γιώργος Αντωνίου ==================== (See Attachement picture) https://dl.dropboxusercontent.com/u/17918482/testimonials_bug.jpg
  9. Pelvis

    [Addon} Modular Front Page

    Solved! Instruction for Others with the same Issue: In Catalog/includes/modules/content/front_page/templates/cm_fp_new_products.php Find This: <div class="row"> And Replace with this: <div class="row" style="display:-webkit-box; display:-webkit-flex; display:-ms-flexbox; display:flex; flex-wrap:wrap;"> -- In Catalog/includes/modules/content/front_page/templates/cm_fp_categories_images.php Find This: <div class="row"> And Replace with this: <div class="row" style="display:-webkit-box; display:-webkit-flex; display:-ms-flexbox; display:flex; flex-wrap:wrap;">
  10. Pelvis

    [Addon} Modular Front Page

    About the Categories Images Content Module. I had the OSC Edge before October with the Filenames. I have now upgrade it to the Latest with Depricated Filnames/Paths and have this Gap. I had the same Isue before and have fix that adding the folowing string in CATALOG/includes/modules/content/front_page/templates/cm_fp_categories_images.php ----- <div class="thumbnail equal-height-categories-images"> ----- and adding the folowing class in user.css .thumbnail .categories-images { height: 30px; padding: 1px; } ---- With the Latest Edge with Depricated Filnames/Paths i can't fix that. See atachment Photo https://dl.dropboxusercontent.com/u/17918482/osc_edge_gap.jpg
  11. Pelvis

    Display Tax Info V3.0

    Thanks! Solved was my mistake Confusing folders and I put a file that had to come to the "front/modules" folder in "admin/modules" folder to. I had inside the folder /catalog/admin/includes/modules/cfg_modules/ 2 files 1. st_tax_below_price.php (this is only needed in "front/modules" folder and was causing the error) 2. cfgm_store.php Thanks !
  12. Pelvis

    Display Tax Info V3.0

    Yes I Have Installed that before?
  13. Pelvis

    Display Tax Info V3.0

    I installed the Version 3.4 and Become the following Error (in Version 3.3 everything was o.k.) Warning: include(includes/languages/english/modules/cfg_modules/st_tax_below_price.php) [function.include]: failed to open stream: No such file or directory in /users/folder/www/catalog/admin/includes/classes/cfg_modules.php on line 28 Warning: include() [function.include]: Failed opening 'includes/languages/english/modules/cfg_modules/st_tax_below_price.php' for inclusion (include_path='.') in /users/folder/www/catalog/admin/includes/classes/cfg_modules.php on line 28 Fatal error: Class 'st_tax_below_price' not found in /users/folder/www/catalog/admin/includes/classes/cfg_modules.php on line 31 P.S. The Verson is OSC Edge the Newest with Depricaded names-paths ...
  14. Hallo Juanna Its a wonderful addon I mad your Instructions on The cm_footer_account.php I see the Button Disabled but the Button is not working (Click on Disable and nothing happens) After that I thought that you forget something or make a mistake in the code and I changed the code (marked with Red Color) but I can Fix it Nothing happens Again Here is the Changed Code: --------- function enable() { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = 'True' where configuration_key = 'MODULE_THIS_MODULE_STATUS'"); $this->enabled = (MODULE_CONTENT_FOOTER_ACCOUNT_STATUS == 'True'); } function disable() { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = 'False' where configuration_key = 'MODULE_THIS_MODULE_STATUS'"); $this->disable = (MODULE_CONTENT_FOOTER_ACCOUNT_STATUS == 'False'); } --------
  15. Pelvis

    Display Tax Info V3.0

    Maybe this time I am more Lucky and somebody will help I want to display the Product Price Like this: (in the middle the calculated Tax amount) Preis: 5,00€ +19%MwSt.: 0,95€ Total: 5,95€ I Have done This (In Germany the vat is19%) and it displays the vat also the 19 Preis: 5,00€ +19%MwSt.: 19,00€ Total: 5,95€ Here is the Code: ----------- function display_price($products_price, $products_tax, $quantity = 1, $show_tax_info = true) { if(DISPLAY_PRICES_NET_GROSS == 'true' && DISPLAY_PRICE_WITH_TAX == 'true' && $products_price > 0){ return '' . $this->format($products_price * $quantity . '<br /><small>', true, null, null, $products_tax, $show_tax_info) . $this->format($products_tax) . '<br />' . $this->format($this->calculate_price($products_price, $products_tax, $quantity)) . '</small>'; } else{ return $this->format($this->calculate_price($products_price, $products_tax, $quantity)); } } ----------- I don't know how to fix this part: . $this->format($products_tax) Would be happy if somebody could help
  16. Pelvis

    Display Tax Info V3.0

    I found the error In the data base at the Table "zones_to_geo_zones" the "zone_id" of the default zone must set to "0" it was set to "1" that "1" was giving the wrong tax calculation. If someone has the same problem the solution is set in the Table "zones_to_geo_zones" the "zone_id" to "0"
  17. Pelvis

    Display Tax Info V3.0

    What's Happening her With 19% Tax in Germany for a Product that Cost 5.00 EURO Net Price When in Configuration Display Prices with Tax "False" everything is fine I see 5.00 EURO. But when I Turn Display Prices with Tax "True" I see the amount of 16,28. It has nothing to do with the Modul when I Turn the Module off I see the same wrong number 16.28 I post it her because of the strange Tax amount under the price see the attached Pictures. https://www.dropbox.com/s/xrnfyxd6iu75zfl/Display%20Prices%20with%20Tax19%25_True.jpg?dl=0 https://www.dropbox.com/s/pu776n1q0r9hjn8/Display%20Prices%20with%20Tax19%25_False.jpg?dl=0
  18. Hallo Rainer Can You Check Please hier :-) Something seams to be wrong with the Versions and the time that you have Upload the Packages Holiday-Promotional Message BS 1.2 -> are from Juni (old) Version 1.1 -> are from Juli (New) And the Data inside if you Look at the version 1.0.zip the files are from Juli (new) if you look at the newest version 1.2.zip the files are from Juni also Older ? What's the newest package with the Corrections from the support thread 1.0 or 1.2 I think 1.0.zip is newer!
  19. Englisch The Problem was in the German Language File: Catalog/includes/languages/german/modules/content/footer/cm_footer_popup.php Find this: ------------- <?php <?php define('MODULE_CONTENT_FOOTER_POPUP_TITLE', 'Info Popup'); define('MODULE_CONTENT_FOOTER_POPUP_DESCRIPTION', 'Das Info Popup hinzufügen'); ------------- and Replace with this: ------------- <?php define('MODULE_CONTENT_FOOTER_POPUP_TITLE', 'Info Popup'); define('MODULE_CONTENT_FOOTER_POPUP_DESCRIPTION', 'Das Info Popup hinzufügen'); ------------- German Das problem lag in der Deutschen Sprachen datei: Catalog/includes/languages/german/modules/content/footer/cm_footer_popup.php Stadt dies (was die Fehlfunktion verursacht) ------------- <?php <?php define('MODULE_CONTENT_FOOTER_POPUP_TITLE', 'Info Popup'); define('MODULE_CONTENT_FOOTER_POPUP_DESCRIPTION', 'Das Info Popup hinzufügen'); ------------- soll man mit dieses ersetzen: ------------- <?php define('MODULE_CONTENT_FOOTER_POPUP_TITLE', 'Info Popup'); define('MODULE_CONTENT_FOOTER_POPUP_DESCRIPTION', 'Das Info Popup hinzufügen'); ------------- Der Fehler war der zweite "<?php"
  20. Englisch it seems that the Modul don't work any more with the new version of BS Edge. It seems the that you can;t click at an ellemnt of the site. I will Check the files again and come back later. German Es sieht so aus das das Modul nicht mehr kompatible mit den neuesten Dateien von Oscommerce BS Edge ist. Den ganzen Tag hab ich versucht das problem zu finden ...nichts. Man kann auf der Seite nichts Auswahlen, wen man mit der Maus auf klickbaren Sachen drauf geht kann man sie nicht Auswahlen. Es langt nicht das module auf false zu stellen um die Sache zu korrigieren man mus das Modul durch Uninstall entfernen dann lauft alles wieder gut. Werde mich wieder melden will noch mall kontrollieren ob alle Dateien richtig sind.
  21. Pelvis

    B2B for 2.3.3

    I don't know if its off topic but I installed the "Total B2B" in OSC (BS) and in login.php I get this error? Fatal error: Call to undefined function tep_draw_password_field() in /users/xxx/www/oscbs/login.php on line 126
  22. Pelvis

    Header Tags for novices

    And a Last question What is the corect code for catalog/product_info.php This: ------------------------- <title><?php echo $header_tags[products_name]; ?></title> ------------------------- Or This (from the last Install Instructions): ------------------------- <title><?php echo $header_tags[title_tag]; ?></title> <meta name="description" content="<?php echo $header_tags[desc_tag]; ?>"> <meta name="keywords" content="<?php echo $header_tags[keywords_tag]; ?>"> -------------------------- Thanks for your time!
  23. Pelvis

    Header Tags for novices

    (sorry for my very bad English) Ken Thanks for that Great Work So the Contrib is working great in osc 2.2 Today i installed it on new osc 2.31 All steps was same except 2 changes 1. Change ----------------------------- in admin/includes/boxes/catalog.php I wrote array( 'code' => FILENAME_HEADER_TAGS_CATEGORY_EDIT, 'title' => BOX_CATALOG_HEADER_TAGS_CATEGORY_EDIT, 'link' => tep_href_link(FILENAME_HEADER_TAGS_CATEGORY_EDIT) ), array( 'code' => FILENAME_HEADER_TAGS_EDIT, 'title' => BOX_CATALOG_HEADER_TAGS_EDIT, 'link' => tep_href_link(FILENAME_HEADER_TAGS_EDIT) ), ---------------------- 2. Change In osc 2.31 at index.php & product_info.php there is no title tag: but there is a link to a file called template_top.php and the title tag is in there so i give the code for the index.php there. The problem is that at product_info.php there is the same link to the same template_top.php file but in the instructions the code for the title tag in product_info.php are Different than the title tag in index.php So i made a new file (copy from template_top.php) renamed it template_top_products.php and put the code for the Products title tag there and renamed the link from product_info.php to template_top_products.php where the Products title tag is present. Of course you can only understand that if you have installed osc2.31 did you? Or has somebody else installed this great Contrib in osc2.31 Thanks friends
×