Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Demitry

Members
  • Content count

    535
  • Joined

  • Last visited

  • Days Won

    25

Demitry last won the day on February 18 2022

Demitry had the most liked content!

5 Followers

Profile Information

Recent Profile Visitors

19,446 profile views

Single Status Update

See all updates by Demitry

  1. strange! i moved with my bootstrapped oscommerce to a new server (debian9, php7, mariadb) and mysql session timeout does not work again. even with the modifications from your addon. but only in admin. catalog user sessions timout as expected. any idea where to look?

    Regards,

    Stephan

    1. Demitry

      Demitry

      hi Stephan,

      I am not familiar with the debian9 OS and mariaDB. However, after googling the mySQL to mariaDB migration, I found some session issues that others have experienced as well. Here is just one of such forum threads.

      https://mariadb.com/kb/en/library/migrating-from-mysql-mariadb-server-closing-client-connections-unexpectedly/

      Here the discussion is regarding the client sessions, however, I know that you mentioned it was the admin panel session that was the issue. There is mention in this thread of overriding the session settings using a wait_timeout directive. Unfortunately I am not familiar enough with this database to tell you how & where to set this setting or whether it will resolve the admin panel session issue you have.

      If you can find your way around code, I suggest to see if this or another fix will solve the problem, otherwise try to contact tech support at www.mariadb.com and see if they can help with this issue. It seems like others have the same problem, so I'm sure they have a solution for it.

      I found this recent osC forum too, though not much help on there.

      I apologize that I could not be of more help.

      Demitry

       

    2. Demitry

      Demitry

      also, check to make sure that the entry in the admin panel for the admin session is numbers only. I added a condition to make sure that the entered data is numeric, and more than 30 seconds. It should be line 34 in /admin/includes/functions/sessions.php

      if (is_numeric(SESSION_EXPIRATION_ADMIN) && SESSION_EXPIRATION_ADMIN > 30) {

      That means that if you enter anything other than numbers, or a number less than 30 seconds, or leave that field blank, it will revert to server-side session settings.

       

    3. Stephan Gebbers

      Stephan Gebbers

      thanks for looking into it. i had it working just fine with similar changes as you have in your addon. when i switched to the new server, my changes stopped working. i tried your addon, wich is basicly what i had plus admin settings, but no luck.

      i guess i have to find out what is different between admin and catalog sessions, as only the admin session is not expiring on the new server now.

    4. Show next comments  3 more
×