Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

mlcy44

Members
  • Content count

    29
  • Joined

  • Last visited

Profile Information

  1. it is not that you can't, but you got to do extra data processing to get your product based on your product name that retrieved from the url. it might be easier for data retrieval to have extra column in product table to hold the url value as: product_name.html or product_name.
  2. ah, thanks for your info, jack. :lol:
  3. hi there, i have installed the header tag, and it works well. i got a question regarding the output from includes/header_tags.php. it outputs this meta tag in the head section, it is hard-coded in the file: <meta name="robots" content="noodp" /> can any one explain to me what the "noodp" does or what it means in that meta tag? cuz when i look up meta tag robots, it should contain text, such as: all, index, follow, none, etc. thanks in advance.
  4. arh.. i can't believe what i found! the reason this error happened is because there is a extra empty line after the ?> in includes/english/modules/shipping/nextday.php. oh well, at least it works now.
  5. hi there, i have installed the osc successfully. then i tried to add an extra shipping option by specifying the shipping cost, but not brand. i followed the way how flat shipping generated, i created a file nextday.php in /includes/modules/shipping/ and includes/english/modules/shipping/. those files are same as flat.php, just changed "flat" to "nextday". i can install the new shipping option in the admin interface without problem. but when i tried to check out stuff, i got error on this page: http://localhost/osc/checkout_shipping.php?n=1 Warning: Cannot modify header information - headers already sent by (output started at c:\inetpub\wwwroot\template50\includes\languages\english\modules\shipping\nextday.php:18) in c:\inetpub\wwwroot\template50\includes\functions\general.php on line 29 i don't have any clue what caused this happen. if anyone knows what is wrong, help me please. thanks alot.
  6. thanks, i will give it a try.
  7. hi there, i have installed the seo url, it works great most of time. just sometimes, button after adding stuff to shopping cart, i mouse over the "continue shopping" button, it shows the url is product_info.php?pid=1243, instead of the seo type url. when i clicked it, it changed the browser's address bar to http://www..../product_info.php?pid=1234, and displayed an error msg: the page is not properly redirect. it doesn't happen very often, and i can't find the reason what causes it. does any one have any idea what this happened? help please.
  8. mlcy44

    fast easy checkout

    hi there, i just installed the fec, i have selected to use create_account2.php for check out. after customer fills in info on create_account2.php, i click next, it gave me an error: 0 - insert into customers_info (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('0', '0', now()) which the query is from: tep_db_perform(TABLE_CUSTOMERS, $sql_data_array); $customer_id = tep_db_insert_id(); tep_db_query("insert into " . TABLE_CUSTOMERS_INFO . " (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('" . (int)$customer_id . "', '0', now())"); is the $customer_id supposed to be 0? i have checked the "tep_db_perform(TABLE_CUSTOMERS, $sql_data_array); " does insert the record for the customer, but "$customer_id = tep_db_insert_id();" didn't get the customer_id out. do i miss anything anywhere? or anything i didn't set up? please help. thanks.
  9. YES! it fixed the problem, thanks alot for you help. :lol:
  10. i got this: Permissions: 755 - 0 what is the $filenameInc? did i miss anything somewhere?
  11. i did. it is 777 on the image folder. i set the header_tags.php for 777 too. but it still shows the error msg. it shows on these pages: admin/header_tags_controller.php?selected_box=header%20tags admin/header_tags_controller.php on page: admin/header_tags_english.php, i only see: Permissions settings for the /public_html/osc/includes/languages/english/header_tags.php file appear to be incorrect and no error msg on this: admin/header_tags_fill_tags.php page.
  12. i have tried to install on a linux host too, and set those files permissions to 777, but i still get those 2 errors. please help.
  13. hi, i just installed the header tags, no error. when i went to admin/header_tags_controller.php?selected_box=header%20tags, i saw these msg at the top: Permissions settings for the c:/inetpub/wwwroot/template50/includes/header_tags.php file appear to be incorrect Error Permissions settings for the c:/inetpub/wwwroot/template50/includes/languages/english/header_tags.php file appear to be incorrect i am using window xp, php4.4, mysql 5.0. i have tried setting the security rights for those 2 files: IUSER, users but still getting the same errors. can anyone tell me what user i need to set for this? thanks alot.
×