Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

mreish

Members
  • Content count

    13
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    mike reish
  1. I got this cotribution installed and working without too much trouble. This is good condidering the voids in my PHP knowledge. Now here's my question. I have two create_account files. One for the general public and one for new members. I'd like to change the member to default to 'Member' instead of retail. Editing the table isn't an option as they'd both default to 'Member', right?
  2. I made my own. It doesn't quite match but it's good enough for the Admin side. I'll leave it here for a few more weeks.
  3. My coupons are working well but they're not tracking. I noticed one other fellow having a similar problem. Sterling suggested... I checked each of those files and noticed there is an insert table_coupon_redeem_track there but still no go. Anyone else have any ideas?
  4. Actually it seems to be working now. I did notice that the products_groups table was empty so I filled that in by hand via myPHPadmin. Now I can add groups through the admin panel. Works pretty well actually. Now, we don't use newsletter (yet) so I don't know if that's boogered or not. Not much help, I know. Sorry. I'll keep experiementing.
  5. Well now I'm not so sure. At first I thought it wasn't reading the price for each group in. Now I look at the products_groups table and notice the customers_group_price field isn't getting updated. That means all my theories have just gone out the window. I recall (maybe in this thread even) something about the admin side not working properly but I'll have to read more. Maybe someone else has the solution already. If I edit the customers_group_price field by hand it works like a charm!
  6. Hi Thorsten, I'm running MS2 and it almost works. Soooo close. I know that if I actually knew what I was doing with PHP that it'd be solved but I'm just not very bright. Maybe someone else can help us out here?
  7. I dunno. I might be the only one trying to get it to work under MS2. And that's not easy given my low PHP/MySQL knowledge. But I'm willing to sacrifice for the betterment of the community! :D
  8. Huh. Well, I admit defeat with this mod. I'm running MS2 and have three groups setup, retail, member and admin but the same price is showing for all three groups. I'm pretty sure the problem is in my product_info.php. Here's what I have: global $customer_id; $customer_group_query = tep_db_query("select customers_group_id from " . TABLE_CUSTOMERS . " where customers_id = '" . $customer_id . "'"); $customer_group = tep_db_fetch_array($customer_group_query); $customer_group_price_query = tep_db_query("select customers_group_price from " . TABLE_PRODUCTS_GROUPS . " where products_id = '" . $HTTP_GET_VARS['products_id'] . "' and customers_group_id = '" . $customer_group['customers_group_id'] . "'"); if ( $customer_group['customers_group_id'] != 0) { if ($customer_group_price = tep_db_fetch_array($customer_group_price_query)) { $products_price = $currencies->display_price($customer_group_price['customers_group_price'], tep_get_tax_rate($product_info_values['products_tax_class_id'])); } else { $products_price = $currencies->display_price($product_info_values['products_price'], tep_get_tax_rate($product_info_values['products_tax_class_id'])); } } else { $products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info_values['products_tax_class_id'])); }
×