News

osCommerce Online Merchant v3.0 and PHP 5
18th July 2007 by Harald Ponce de Leon

The PHP Group recently announced that support for PHP 4 will be discontinued at the end of this year to focus on the production-ready PHP 5 and the upcoming PHP 6 releases.

The announcement from the PHP Group can be read here:

http://www.php.net/index.php#2007-07-13-1

This announcement impacts our current v3.0 development roadmap, our vision for the final v3.0 release, and our support policy for released versions, where we have decided to also drop support for PHP 4 in osCommerce Online Merchant v3.0 and to optimize it for PHP 5.

This gives us v3.0 Alpha 5 and v3.0 Alpha 6 to remove PHP 4 compatibility coding logic and to optimize the framework with the new features PHP 5 provides. As the current state of the v3.0 framework has already moved to an Object Oriented design, optimizing it for PHP 5 will be a simple task worth doing now to avoid jumping to v4.0 so soon which was planned to be PHP 5 optimized.

Optimizing osCommerce Online Merchant v3.0 for PHP 5 now allows us to further improve and strengthen the framework and to pass the high quality level of coding to community developers to base their add-ons on. The performance of the framework will improve by removing the PHP 4 compatibility layer and by taking advantage of the new features PHP 5 provides such as SimpleXML, DateTime, Iterators, and new core functions. The design and security of the Object Oriented framework will also improve by utilizing the new features of the PHP 5 Object Model.

Our support policy for the v3.x release series is to publish a release with new features every 6 months and to support each published release for 2 years. Removing the PHP 4 compatibility layer now for the v3.0 release allows us to focus only on PHP 5 without the need to spend resources on PHP 4 compatibility past its end of life cycle.

Many hosting providers have been supporting PHP 5 in recent years together with PHP 4 where this change will not impact many users. The number of providers supporting PHP 5 will increase by the end of the year to match the end of life support for PHP 4.

The osCommerce Online Merchant v2.x release series will continue to be compatible with PHP 3, PHP 4, and PHP 5 from v2.2 onwards.

We are highly motivated about this change in focus and look forward in making osCommerce Online Merchant v3.0 an even better release.

This announcement can be discussed on the community support forums at:

http://forums.oscommerce.com/index.php?showtopic=270025

Back to listing